Captcha no funciona

More
5 years 5 months ago #81219 by czam
czam created the topic: Captcha no funciona
Buen día,

Acabo de montar la ulitma version de lime survey en un hosting limesurvey192plus-build120530. Cuando tengo una encuesta o cuando en las plantillas pruebo en template editor y Save Page no se pude ver el captcha.

Verificando el archivo index.php se encuentra de la siguiente forma el llamado a la funcion de verificacion: src='$rooturl/verification.php?sid=$surveyid'

El htaccess.txt dentro de la raiz de donde esta el aplicativo tiene la siguiente configuración:


<IfModule mod_rewrite.c>

RewriteEngine Off

## DONT TOUCH ANYTHING ##
# Only with survey code
# server.fr/123456
RewriteRule ^([0-9]+)/*$ index.php?sid=$1 [L,QSA]

# Survey code + Lang : server.fr/123456/lang-fr
RewriteRule ^([0-9]+)/lang-([^/]*)/*$ index.php?sid=$1&lang=$2 [L,QSA]

# Survey code + Lang + Token : server.fr/123456/lang-fr/tk-sdlfkjozeiru
RewriteRule ^([0-9]+)/lang-([^/]*)/tk-([^/]*)/*$ index.php?sid=$1&lang=$2&token=$3 [L,QSA]

# Survey code + Token : server.fr/123456/tk-sdlfkjozeiru
RewriteRule ^([0-9]+)/tk-([^/]*)/*$ index.php?sid=$1&token=$2 [L,QSA]
</IfModule>


Aún así no logro que el captcha se mueste en mi site.

Qué puedo hacer?

Agradezco su ayuda! =)

Please Log in to join the conversation.

More
5 years 5 months ago #81225 by Ben_V
Ben_V replied the topic: Captcha no funciona
Hola...
una pregunta:
Esta parte en las opciones generales de la encuesta (ver captura de pantalla) la tienes bien configurada?


Ben/
Nota: el htaccess no tiene nada que ver con todo eso ;)

Benoît

EM Variables => bit.ly/1TKQyNu | EM Roadmap => bit.ly/1UTrOB4
Last Releases => 2.6x.x goo.gl/ztWfIV | 2.06/2.6.x => bit.ly/1Qv44A1
Demo Surveys => goo.gl/HuR6Xe (already included in /docs/demosurveys)
Attachments:

Please Log in to join the conversation.

More
5 years 5 months ago #81226 by czam
czam replied the topic: Captcha no funciona
Hola, muchas gracias por tu aclaración.

Efectivamente la encuesta se encuentra configurada para unicamente mostrarlo para guardar y recuperar encuesta como se ve en las imagenes. pero aún así no me aparece.





Gracias
Attachments:

Please Log in to join the conversation.

More
5 years 5 months ago - 5 years 5 months ago #81257 by Ben_V
Ben_V replied the topic: Captcha no funciona
Puede ser que tengas un archivo que no se haya copiado correctemente cuando has subido el programa al servidor...

Lo que haria en tu caso antes de buscar más alla:
1) Lo mas suave:
Subir de nuevo el archivo /verification.php

2) Si tampoco te funcciona
a) haces una copia de seguridad de tu fichero /config.php y de todos los que hayas modificado si acaso....
b) subes de nuevo toda la carpeta Limesurvey (192plus-build120530) (sobreescribir todos los archivos) excepte:
- /config.php
- carpetas: /locale /templates /upload

nota:
- tendras que cambiar el nombre de la carpeta /admin/install para poder acceder a tu installación
- echar un vistazo a las permisiones lectura/escritura de las carpetas...

Ben/

Benoît

EM Variables => bit.ly/1TKQyNu | EM Roadmap => bit.ly/1UTrOB4
Last Releases => 2.6x.x goo.gl/ztWfIV | 2.06/2.6.x => bit.ly/1Qv44A1
Demo Surveys => goo.gl/HuR6Xe (already included in /docs/demosurveys)
Last Edit: 5 years 5 months ago by Ben_V.

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!