Error por cambio de version de PHP

More
1 year 1 month ago #144273 by jcgolo
jcgolo created the topic: Error por cambio de version de PHP
Hola, tengo instalado una versión vieja de Moodle. En el proceso de migración hacia una version mas nueva actualizé la version de PHP de 5.29 a 5.6.27
AL hacer eso entro en limesurvey y me da el error que muestra la pantalla
Tengo instalado el limesurver desde agosto del 2013
Alguien me podrá ayudar por favor, gracias
Attachments:

Please Log in to join the conversation.

More
1 year 3 weeks ago #144552 by holch
holch replied the topic: Error por cambio de version de PHP
Normalmente Limesurvey no deveria tener problemas con la version 5.6. si es una version reciente.

Que versión de LS estas usando? Si lo tienes instalado desde 2013 y no has hecho updates, es bien possible que el problema es tu versión de LS.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
1 year 3 weeks ago #144560 by jcgolo
jcgolo replied the topic: Error por cambio de version de PHP
Muchas gracias por la ayuda
Lo tengo instalado desde agosto del 2013, pero no se la versión. No encuentro donde figura
Me podrás decir donde buscar. Gracias

Please Log in to join the conversation.

More
1 year 3 weeks ago #144561 by Ben_V
Ben_V replied the topic: Error por cambio de version de PHP
en el pie de pagina de la admin despues de haber entrado con tu credenciales..

Benoît

EM Variables => bit.ly/1TKQyNu | EM Roadmap => bit.ly/1UTrOB4
Last Releases => 2.6x.x goo.gl/ztWfIV | 2.06/2.6.x => bit.ly/1Qv44A1
Demo Surveys => goo.gl/HuR6Xe (already included in /docs/demosurveys)

Please Log in to join the conversation.

More
1 year 3 weeks ago #144567 by jcgolo
jcgolo replied the topic: Error por cambio de version de PHP
Pero no puedo entrar.
Necesito saber en que archivo figura la versión. Estuve buscando y hasta ahora no lo encuentro
Gracias

Please Log in to join the conversation.

More
1 year 3 weeks ago #144570 by Ben_V
Ben_V replied the topic: Error por cambio de version de PHP
depende de la versión :laugh:

/version.php

sino:

/application/config/version.php

Benoît

EM Variables => bit.ly/1TKQyNu | EM Roadmap => bit.ly/1UTrOB4
Last Releases => 2.6x.x goo.gl/ztWfIV | 2.06/2.6.x => bit.ly/1Qv44A1
Demo Surveys => goo.gl/HuR6Xe (already included in /docs/demosurveys)

Please Log in to join the conversation.

More
1 year 3 weeks ago #144571 by jcgolo
jcgolo replied the topic: Error por cambio de version de PHP
Finalmente!!
$config = "2.00+";
$config = 164;
$config = '130708';

Please Log in to join the conversation.

More
1 year 3 weeks ago #144573 by holch
holch replied the topic: Error por cambio de version de PHP
Eso es una versión muy antigua. Tiene mas que 3 años, entonces es bien possible que el problema es esse.

Lo que podrias hacer es instalar una version mas reciente de Limesurvey (2.06 es mas parecido a tu version, en 2.55 la gui es muy diferente). Ai conectas a la base de dados antigua y normalmente deberia fucionar. Pero antes de qualquer cosa, haz un backup de la base de dados e de tu instalación.

Si no tienes dados importantes, entonces podrias simplemente instalar una nueva versión, pero me imagino que no quieres perder los dados de la versión anterior, entonces toma cuidado.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
1 year 3 weeks ago - 1 year 3 weeks ago #144574 by Ben_V
Ben_V replied the topic: Error por cambio de version de PHP
Requisitos para v2.00:
  • *MySQL 4.1.0 or later OR Microsoft SQL Server 2005 or later OR Postgres 8.1 or later
  • *PHP 5.1.6 or later

Requisitos para v2.06 (2.6):
  • *MySQL 4.1.0 or later OR Microsoft SQL Server 2005 or later OR Postgres 8.1 or later
  • *PHP 5.3.3 or later

Requisitos para v2.5x:
  • *MySQL 5.5.3 or later OR Microsoft SQL Server 2005 or later OR Postgres 8.1 or later
  • *PHP 5.3.3 or later
NO habia visto que no habias todavia instalado la nueva versión
Ahora tendrias que verificar:
  1. que tu instalación cumple con los requisitos MySQL
  2. que se ha creado el archivo /application/config/config.php
  3. que los datos de conexión con la bbdd son mismos que en tu antiguo archivo /config.php

Benoît

EM Variables => bit.ly/1TKQyNu | EM Roadmap => bit.ly/1UTrOB4
Last Releases => 2.6x.x goo.gl/ztWfIV | 2.06/2.6.x => bit.ly/1Qv44A1
Demo Surveys => goo.gl/HuR6Xe (already included in /docs/demosurveys)
Last Edit: 1 year 3 weeks ago by Ben_V.

Please Log in to join the conversation.

More
1 year 3 weeks ago #144579 by jcgolo
jcgolo replied the topic: Error por cambio de version de PHP
Muchas gracias!

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!