instalacion

More
2 years 2 months ago #123326 by pmartinez
pmartinez created the topic: instalacion
buenas tardes,
cabe aclarar que la instalación la estoy realizando en linux debian 7

tengo problemas en el proceso de ejecucion del script de instalación, luego de ir rellenando la informacion requerida para conexion a la base de datos y de realizar el test para comprobar las dependencias que necesita que me da todo correcto elijo el idioma y reenvia a una direccion en el servidor que me dice que no existe http://ipserver/limesurvey/index.php/surveys/publiclist?lang=es
este es el mensaje:
Not Found
The requested URL /limesurvey/index.php/surveys/publiclist was not found on this server.
Apache/2.2.22 (Debian) Server at asterisk.europesip-local.com Port 80

he comprobado la base de datos y ha creado correctamente la base y las tablas.

me podéis echar una mano

Please Log in to join the conversation.

More
2 years 2 months ago #123352 by pmartinez
pmartinez replied the topic: instalacion
hola ,

algún comentario???

Please Log in to join the conversation.

More
2 years 2 months ago #123408 by pmartinez
pmartinez replied the topic: instalacion

pmartinez wrote: buenas tardes,
cabe aclarar que la instalación la estoy realizando en linux debian 7

tengo problemas en el proceso de ejecucion del script de instalación, luego de ir rellenando la informacion requerida para conexion a la base de datos y de realizar el test para comprobar las dependencias que necesita que me da todo correcto elijo el idioma y reenvia a una direccion en el servidor que me dice que no existe http://ipserver/limesurvey/index.php/surveys/publiclist?lang=es
este es el mensaje:
Not Found
The requested URL /limesurvey/index.php/surveys/publiclist was not found on this server.
Apache/2.2.22 (Debian) Server at localhost.com Port 80

he comprobado la base de datos y ha creado correctamente la base y las tablas.

me podéis echar una mano

Please Log in to join the conversation.

More
2 years 2 months ago - 2 years 2 months ago #123415 by LouisGac
LouisGac replied the topic: instalacion
bueno, eso es un error de apache, no de limesurvey.

esta activado en tu server el url rewriting ?

Prueba esta direccion :
{limesurvey root}/index.php/admin/survey/sa/index

y si no functiona, en application/config/config.php cambia :
'urlFormat' => 'path',

por :
'urlFormat' => 'get',

y prueba esta direccion :
{limesurvey root}/index.php?r=admin/labels/
Last Edit: 2 years 2 months ago by LouisGac.

Please Log in to join the conversation.

More
2 years 2 months ago #123483 by pmartinez
pmartinez replied the topic: instalacion
hola,
gracias por la respuesta, al final el problema se ha solucionado modificando la linea que me comentabas
la he dejado tal cual y perfecto.
'urlFormat' => 'get'

aquí se genera un nuevo fallo,
el script de instalación no crea el usuario que pide.
otra cosa interesante que he visto en las tablas es que el password es tipo blob por lo cual me parece muy extraño

en definitiva el script crea la base y tablas pero no crea el usuario para logarme por lo cual no puedo acceder

un saludo

Please Log in to join the conversation.

More
2 years 2 months ago #123855 by pmartinez
pmartinez replied the topic: instalacion
no se que mas hacer dados los errores de creación de la base de datos, me parece bastente poco pulido el software

si me pueden explicar que es lo que se debe hacer para poder cargar una base de datos que funcione bien y el codigo que se debe modificar para que funcione os estaré muy agradecidos


desde ya muchas gracias

Please Log in to join the conversation.

More
2 years 2 months ago #123861 by pmartinez
pmartinez replied the topic: instalacion
he realizado todo el proceso de creacion de base de datos y creacion de usuario a traves del portal web, a la hora de logarme con el usuario que debe a ver creado me dice contraseña erronea.
lo que he echo es ir a mirar a la base de datos a ver si realmente crea dicho usuaio y me doy cuenta que no ha escrito nada en la tabla users.
aqui os dejo la consulta de la base de datos

algo que tampoco me termina de gustar es que el formato del password es blob :blink:

mysql> desc users;
+
+
+
+
+
+
+
| Field | Type | Null | Key | Default | Extra |
+
+
+
+
+
+
+
| uid | int(11) | NO | PRI | NULL | auto_increment |
| users_name | varchar(64) | NO | UNI | | |
| password | blob | NO | | NULL | |
| full_name | varchar(50) | NO | | NULL | |
| parent_id | int(11) | NO | | NULL | |
| lang | varchar(20) | YES | | NULL | |
| email | varchar(254) | YES | | NULL | |
| htmleditormode | varchar(7) | YES | | default | |
| templateeditormode | varchar(7) | NO | | default | |
| questionselectormode | varchar(7) | NO | | default | |
| one_time_pw | blob | YES | | NULL | |
| dateformat | int(11) | NO | | 1 | |
| created | datetime | YES | | NULL | |
| modified | datetime | YES | | NULL | |
+
+
+
+
+
+
+
14 rows in set (0.01 sec)

mysql> select * from users;
Empty set (0.00 sec)

Please Log in to join the conversation.

More
2 years 1 month ago #124010 by holch
holch replied the topic: instalacion
Yo nunca he tenido problemas instalar Limesurvey, si el servidor cumple todo lo que Limesurvey pide.

Tu servidor oferece todo eso abajo? ( manual.limesurvey.org/Installation#Make_...rvey_on_your_website )

Required:
Minimum 200 MB disk space
MySQL 4.1.0 or later OR Microsoft SQL Server 2005 or later OR Postgres 8.1 or later
PHP 5.3 or later with the following modules/libraries enabled:


Has intentado con otro servidor? Los errores que comentas parecen muy extraños.

Que version estas instalando? Usas un instaldor de tu provider o usas la version oferecido aqui en Limesurvey.org?

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
2 years 1 month ago #124108 by pmartinez
pmartinez replied the topic: instalacion
No he probado en otro server pero los requisitos están más que superados, la versión que he instalado es la ultima que ofrece limesurvey en la su página web.
Como verás la base de datos que genera a mi entender tiene fallos. Será que encontré algún bug?
He seguido el manual que me estas ofreciendo en el link. De echo el fallo creó yo que no es de requerimientos ya que genera la base de datos y antes de generar la base ya comprueba si los requisitos se cumplen, igualmente los he comprobado con anterioridad.
El fallos es evidentemente que no crea el usuario y que en el campo password del usuario le coloca un tipo password formato imagen, no creó que tenga nada que ver con los requisitos. Si tienes una versión que funcione por favor enviame el link para instalarlo.

Desde ya muchas gracias

Please Log in to join the conversation.

More
2 years 1 month ago #124112 by holch
holch replied the topic: instalacion
Hmmm,, para mi, la última version está funcionando sin problemas. Pero he instalado hace un tiempo y desde entonces he hecho los updates por el GUI. Entonces no puedo tener certeza que no haya algun problema con la instalcion completamente nueva con la nueva version. Pero no he leid nada de uns problema similar aqui en el forum, entonces yo creo que tiene algun problema especificamente con tu instalacion.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now