Question is corrupt: no type defined for question

More
8 months 1 week ago #165101 by holch
holch replied the topic: Question is corrupt: no type defined for question
Nunca usa updates do Softalicious. Ninguem sabe o que eles estão mudando no software. Hoje, instalar Limesurvey é super simples, então sempre faça você mesmo. Seguramente vai te dar melhores resultados.
Muita sorte.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in or Create an account to join the conversation.

More
8 months 1 week ago #165108 by jorge_ici
jorge_ici replied the topic: Question is corrupt: no type defined for question
Novidade: acabei de efetuar uma instalação paralela e o problema mantém-se:

Erro Interno Do Servidor
Question is corrupt: no type defined for question 1
Ocorreu um erro interno enquanto o servidor Web processava sua requisição. Por favor entre contate the webmaster para relatar esse problema.
Obrigado.

Please Log in or Create an account to join the conversation.

More
8 months 1 week ago #165110 by holch
holch replied the topic: Question is corrupt: no type defined for question
Como você instalou? Fez o download do arquivo zip aqui em Limesurvey.org ou você usou o Softalicious?

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in or Create an account to join the conversation.

More
8 months 1 week ago #165111 by jorge_ici
jorge_ici replied the topic: Question is corrupt: no type defined for question
Usei o Softaculous.

Please Log in or Create an account to join the conversation.

More
8 months 1 week ago #165112 by holch
holch replied the topic: Question is corrupt: no type defined for question
Também vejo que a tradução em portugues da mensagem de erro é meio errado...

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in or Create an account to join the conversation.

More
8 months 1 week ago #165114 by jorge_ici
jorge_ici replied the topic: Question is corrupt: no type defined for question
Exato!

Please Log in or Create an account to join the conversation.

More
8 months 1 week ago #165115 by holch
holch replied the topic: Question is corrupt: no type defined for question
Hmm, minha preocupação é que isso é um problema com o Softalicous porque eu instalei o 3.x.x do zero e não tenho problema nenhum. Tenta fazer o download e instalar sem o Softalicous. Não é muito complicado.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in or Create an account to join the conversation.

More
8 months 1 day ago #165520 by jorge_ici
jorge_ici replied the topic: Question is corrupt: no type defined for question
Finalmente tive algum tempo para tentar instalar sem o Softaculous. Transferi para o meu PC, descompactei a instalação e transferi-a, via FTP, para um novo diretório. Criei uma nova BD (e um utilizador para esta nova BD, com permissões totais) no MySQL, porém, quando acedo ao diretório para a instalação (e surge o LimeSurvey installer a 10%) e carrego no botão [Start Installation] recebo esta mensagem:

Bad Request
The CSRF token could not be verified.
The request could not be understood by the server due to malformed syntax. Please do not repeat the request without modifications.
If you think this is a server error, please contact the webmaster.

Está difícil... alguma ideia sobre este erro?

Please Log in or Create an account to join the conversation.

More
7 months 4 weeks ago #165588 by jorge_ici
jorge_ici replied the topic: Question is corrupt: no type defined for question
Novidades: com mais calma estive a rever as instruções de instalação e dei conta de que fiz upload dos ficheiros em modo ASCII. Apaguei tudo e voltar a transferir os ficheiros para o servidor em modo BINÁRIO e a instalação decorreu sem problemas.

Resultado: o LimeSurvey está instalado, com tudo a funcionar, excepto a opção [Lista de Seleção ("Dropdown")] nas [Perguntas de Escolha Única]. Portanto, esta opção, continua inacessível, mesmo com uma nova instalação.

Hipótese: durante o upload dos ficheiros para o servidor, fui confrontado com cerca de duas dezenas de questões sobre ficheiros já existentes. Os que estavam com tamanho zero (0 kb) dei instrução para serem substituídos (pelos ficheiros com tamanho >0); já os ficheiros com o mesmo tamanho, dei instrução para permanecerem aqueles com a data mais recente. Radicará em algumas destas substituições a causa do problema que apresento?

Please Log in or Create an account to join the conversation.

More
7 months 4 weeks ago #165598 by jorge_ici
jorge_ici replied the topic: Question is corrupt: no type defined for question
Problema resolvido: apaguei e reinstalei tudo. Porém, desta vez, durante o upload dos ficheiros para o servidor (em modo BINÁRIO), quando fui confrontado com o que fazer com os ficheiros já existentes (i.e., substituir, ignorar, etc.), dei a instrução geral para permanecerem aqueles com a data mais recente (independentemente do seu tamanho).

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!