Check out the LimeSurvey source code on GitHub!

[an error occurred while processing this directive]

3 years 6 months ago #99146 by tbwaiyaki
I have recently installed Limesurvey (Version 2.00+ Build 130526) on my domain site. I have also installed a copy locally on a virtual machine running Ubuntu 12 (Precise Pangolin) which I used to test the survey. The survey included a number of text arrays requiring numbers only, with totals on rows and columns. There about 8 of these with the Y-values filtered by an earlier list of 15 values.

At first all was well, but as I increased the text arrays the completed survey would end with the error:

[an error occurred while processing this directive] on a blank page.

Also, on examining the results submitted on both sites, they were all empty. Note that on the Ubuntu, I had split the survey into 3 groups and the results for the first group would be stored but the rest would be NULLs. Late, even the first group stopped performing any storage.

I have checked permissions on the site and I have tried to increase the php maximum memory allocation, with no effect. I urgently need assistance.


Please Log in to join the conversation.

3 years 5 months ago #99155 by tbwaiyaki
Some additional information:

I was able to get a survey to complete (up to pressing the submit button) and strangely ended up at the standard limesurvey form indicating no surveys are available (see attachment)

I then began deleting survey questions 1 by 1 and after deleting the 6th question, I finally got the 'Thank you' page after submission (see attachment). In this case, data was finally stored in the database. But now I'm 6 questions short!

I would appreciate expert help on this issue. It seems to be a memory problem, probably with the text array widget. What is the solution?


Please Log in to join the conversation.

3 years 5 months ago #99208 by tbwaiyaki
Well, good news!

After extensive research I looked in the error.log file of apache and found this little bit of info:
PHP Warning: Unknown: Input variables exceeded 1000. To increase the limit change max_input_vars in php.ini.

I then located the relevant php.ini file and increased the parameter to 2000. (There were 2 so I changed both). When this did not work, I looked again and removed the unobtrusive little semicolon ';' at the start of the line.


I'm running more tests but I think this one's in the bag!
The following user(s) said Thank You: mdekker

Please Log in to join the conversation.

3 years 5 months ago #99226 by DenisChenu
Not a news ... :whistle:

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

3 years 5 months ago #99279 by tbwaiyaki
Sorry. My first time. I did say 'Good News'

I was given the forum options:
  • Installation & update issues
  • Design issues
  • Can I do this with LimeSurvey?
  • Development
  • Future features
  • News

None seemed to fit so I chose News. It's not even a bug, just a configuration issue with PHP.

Perhaps, in the limesurvey manual, a page could be added discussing the configuration parameters that would have a significant impact on limesurvey users, such as for PHP,JavaScript, linux, etc. This seems particularly important since coding is now part of the limesurvey experience. Just a thought.

Thanks for your response. B)

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form