LimeSurvey 2.0RC5 released

More
4 years 11 months ago #83646 by c_schmitz
c_schmitz created the topic: LimeSurvey 2.0RC5 released
Article cannot be shown

Best regards

Carsten Schmitz
LimeSurvey project leader

Please Log in to join the conversation.

More
4 years 11 months ago #83649 by fransmarcelissen
fransmarcelissen replied the topic: LimeSurvey 2.0RC5 released
When I try to install this version, it fails with "CDbCommand failed to execute the SQL statement: SQLSTATE[42S21]: Column already exists: 1060 Duplicate column name 'date_invited'. The SQL statement executed was: ALTER TABLE `lime_survey_links` ADD `date_invited` datetime NULL default NULL"
This happens also with an empty database. This problem is reported as bug id 06343, but I was wandering whether this happens to everyone. Has anyone succeeded in installing rc5? If so, how did you do this?

I am very curious whether in this version it is possible to use default values. In RC4 this did not work, what made this version useless to me.

Please Log in to join the conversation.

More
4 years 11 months ago #83655 by kaval
kaval replied the topic: LimeSurvey 2.0RC5 released
I tried to install. Both RC4 and RC5 fail to allow me to pick mySQL as the database. RC3 seemed to allow me to select this database. Is PHP5 LDAP library essential to the install as my shared host does not provide this.

On RC3 I was able to complete an install, but the graphic statistics failed to work giving me errors. Overall, the install menu is cleaner that the 1 versions.

Please Log in to join the conversation.

More
4 years 11 months ago - 4 years 11 months ago #83658 by c_schmitz
c_schmitz replied the topic: LimeSurvey 2.0RC6 released
@fransmarcelissen: Regarding the installation error: We just released RC6 where this issue is fixed.

@kaval: You will need to have the mySQL DBO driver installed. The installer shows all DBO drivers that are installed. LDAP is an optional module, not required.

Best regards

Carsten Schmitz
LimeSurvey project leader
Last Edit: 4 years 11 months ago by c_schmitz.

Please Log in to join the conversation.

More
4 years 11 months ago #83661 by fransmarcelissen
fransmarcelissen replied the topic: LimeSurvey 2.0RC5 released
installation now works OK. But the very first (test) survey I try to create breaks with "Undefined variable: xssfilter:"
I have the impression that 2.0 still is not very mature....
Frans

Please Log in to join the conversation.

More
4 years 11 months ago - 4 years 11 months ago #83664 by c_schmitz
c_schmitz replied the topic: LimeSurvey 2.0RC5 released
Well, actually it is but there were many changes since the last release, one which caused this isse. RC7 is out now ;).

Best regards

Carsten Schmitz
LimeSurvey project leader
Last Edit: 4 years 11 months ago by c_schmitz.

Please Log in to join the conversation.

More
4 years 11 months ago - 4 years 11 months ago #83665 by fransmarcelissen
fransmarcelissen replied the topic: LimeSurvey 2.0RC5 released
Default values still do not work.
I created a new survey(test), with one group (test) and one text question (test). Go to the default definition page. Define a default answer. The "default field" on this page now contains the text "TODO - not sure how to access the default value".
This problem is reported in the bug list as 06215 some time ago, but not solved. I hope it will be solved soon, I cannot make any serious surveys without defaults.
Last Edit: 4 years 11 months ago by fransmarcelissen.

Please Log in to join the conversation.

More
4 years 11 months ago #83673 by c_schmitz
c_schmitz replied the topic: LimeSurvey 2.0RC5 released
Well, as you can see that issue waits for feedback from the reporter because we cannot reproduce. Maybe you can attach a small sample survey to reproduce?

Best regards

Carsten Schmitz
LimeSurvey project leader

Please Log in to join the conversation.

More
4 years 11 months ago #83674 by fransmarcelissen
fransmarcelissen replied the topic: LimeSurvey 2.0RC5 released
Remotecontrol not present?
I would like to test remotecontrol. In the documentation it is mentioned:

The basic LSRC2 URL is: http://<your_domain>/<your_limesurvey_dir>/index.php/admin/remotecontrol(external link)
LSRC2 fully complies to the XML-RPC specification(external link) and JSON-RPC specifications. We recommend in general to use JSON-RPC because it is well tested and has a much smaller footprint than XML-RPC.

However, in my ls20 (rc7) there is no directory remotecontrol onder admin. Am I missing something?
Frans

Please Log in to join the conversation.

More
4 years 11 months ago #83678 by c_schmitz
c_schmitz replied the topic: LimeSurvey 2.0RC5 released
Sure it is present. Btw, there is no directory at all under /admin ;).

We are using the Yii framework so the necessary code is in /application/Controllers
/admin/remotecontrol.php

Best regards

Carsten Schmitz
LimeSurvey project leader

Please Log in to join the conversation.

More
4 years 11 months ago #83699 by fransmarcelissen
fransmarcelissen replied the topic: LimeSurvey 2.0RC5 released
>> Default values still do not work.
> Well, as you can see that issue waits for feedback from the reporter because we cannot
>reproduce. Maybe you can attach a small sample survey to reproduce?

It happens with each survey, on each 20RC version until now (july, 21). Just make a survey, make a page, make a (text) question and try to define a default value. Attached here is a picture of the screen that appears then. If I try to save the question, limesurvey disappears into nirwana (a white screen).
I tried to send you an example survey, but it appears that export is also not working (export to lss produces a file with just the text "XMLWriter class not compiled into PHP, please contact your system administrator" in it. I will report this error as well, but I just noticed it now.
I have the impression that there are so many bugs in this (rc7) release, I can better be considered an early alpha. Until now I have not managed to create one working survey.

As said it happens (in my standard, Dutch system) with each survey. I tried to import a 1.92 survey with default values, but then other errors happen.
If you want to see it happen, I can give you the adminstrators login for my system (but I will do this only on email, not on the forum).
Greetz,
Frans
Attachments:

Please Log in to join the conversation.

More
4 years 11 months ago #83822 by kaval
kaval replied the topic: LimeSurvey 2.0RC6 released
Recently upgraded to PHP 5.3.14
Tried installing all optional PHP modules for mySQL
Still only recognizes sqlite and sqlite3 databases, although stable release version has no problem recognizing mySQL database with prompting.

Anything you folks can suggest?
Thanks
Attachments:

Please Log in to join the conversation.

More
4 years 11 months ago #83911 by Mazi
Mazi replied the topic: LimeSurvey 2.0RC5 released
Hi Frans,

this issue should be fixed now, see github.com/LimeSurvey/LimeSurvey/commit/...35ed44b26f79d04ad586

You can alsways grab the latest code base from Github so you don't need to wait for another RC release, see docs.limesurvey.org/Accessing+the+source+code


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
4 years 11 months ago #83912 by Mazi
Mazi replied the topic: LimeSurvey 2.0RC6 released

kaval wrote: Recently upgraded to PHP 5.3.14
Tried installing all optional PHP modules for mySQL
Still only recognizes sqlite and sqlite3 databases, although stable release version has no problem recognizing mySQL database with prompting.

Anything you folks can suggest?
Thanks

Please upload a phpinfo file so we can take a look at your server configuration. Just put the following code into a file named phpinfo.php and upload it to your webserver:
< ?php phpinfo(); ? >
(Delete the spaces next to </> when copying the code.)
After uploading please post the link to the file.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
4 years 11 months ago #83941 by kaval
kaval replied the topic: LimeSurvey 2.0RC6 released
I got the install to work after having the host make sure the DBO for mySQL in PHP was working despite php -m at a terminal level showing the module was intalled.

It seems to me like there are bugs in producing public statistics and graphs which fail, and in setting someof the menu options, so I would agree that perhaps calling ithe product a RC is a bit optimistic at this stage, but it does have a nice installer and I do like some of the configuration options.

Please Log in to join the conversation.

Have you already participated in our survey?

Don't miss your chance to win our valuable prices.

Just click here to start the survey:

Start now

Start now!

Just create your account and start using Limesurvey today.

Register now