Check out the LimeSurvey source code on GitHub!

Ciao Ragazzi

More
4 years 4 months ago #86469 by lfanfoni
inutile reinstallare se prima non disinstalli per bene. guarda nei "servizi", probabilmente c'è un vecchio MySql che va in conflitto con quello installato da Xampp, ed è pure attivo.
Se lo trovi stoppalo e prova di nuovo con xampp. Oppure disinstalla tutto, ma proprio tutto quello che hai messo (xammp, apache, mysql), e ricomincia con xampp completo
The following user(s) said Thank You: drop85

Please Log in to join the conversation.

More
4 years 4 months ago #86470 by drop85
l'ho reinstallato e lo ha riconosciuto... Il problema però rimane:

•Connessione con il database fallita. Verificare la corretteza della posizione (server), nome utente e password del database, quindi riprovare di nuovo

Qui parla di una connessione con il database... ma io database non ne ho ...

Please Log in to join the conversation.

More
4 years 4 months ago #86471 by lfanfoni
Di solito l'installazione di mysql crea il database di default e l'utente "root" con password nulla, sul server denominato "localhost".
Prova a fare admin del mysql da xampp o a digitare http://localhost/phpmyadmin/ sul browser.

Please Log in to join the conversation.

More
4 years 4 months ago #86474 by drop85
Se digito -- localhost/phpmyadmin/ -- mi esce


Benvenuto in phpMyAdmin

Errore

Messaggio di MySQL:
#1045 - Access denied for user 'root'@'localhost' (using password: NO)

Connessione per controluser come definito nella configurazione fallita.

phpMyAdmin ha provato a connettersi al server MySQL, e il server ha rifiutato la connessione. Si dovrebbe controllare il nome dell'host, l'username e la password nel file di configurazione ed assicurarsi che corrispondano alle informazioni fornite dall'amministratore del server MySQL.

Please Log in to join the conversation.

More
4 years 4 months ago #86475 by drop85
Su un sito cè scritto...

Come molte soluzioni PHP, l’installazione è questione di pochi minuti:

scaricare l’ultima versione stable (al momento della scrittura di questo articolo è la 1.92+);
estrarre i file nello spazio web;
aprire il file config.php e modificare le voci $databaselocation, $databasename, $databaseuser, $databasepass inserendo i dati di collegamento al database;
accedere con il browser all’indirizzo dell’applicazione, ad esempio:http://localhost/limesurvey/


Io se apro il file config.php tutte quelle voci non le individuo proprio!

Please Log in to join the conversation.

More
4 years 4 months ago #86476 by lfanfoni
root è l'amministratore del db mysql.
comunque mi arrendo: prova a cercare l'errore sul web, di sicuro trovi qualcuno che ha avuto lo stesso problema.

Please Log in to join the conversation.

More
4 years 4 months ago #86603 by drop85
Grazie mille.. non so come ma ho risolto

Please Log in to join the conversation.

More
9 months 3 weeks ago #135305 by violass
Ciao!

ho provato a seguire tutte le indicazioni descritte nei vostri post passati ma non sono riuscita ad entrare su LS.
seguendo i punti del post #86462 sono arrivata fino al punto 6 poi il punto 7 "verifica che il config.php sia a posto" non capisco a cosa si riferisce. L'ho ignorato e sono passata al punto 8 "fai partire l'admin: localhost/limesurvey/admin" e a questo punto
ho digitato sul broswer "localhost/limesurvey/admin" e non mi trova la pagina
allora
ho cliccato su admin nella finestra di xampp e mi apre una pagina del browser con il DB di SQL e sulla dx c'è indicato che sono entrata con l'account di default "root"

ecco da qui non sono riuscita a trovare la schermata bianca per entrare su lime come descritto nelle istruzioni del manuale ne cambiare utente.

Aiutatemi vi prego :(

Please Log in to join the conversation.

More
9 months 3 weeks ago #135307 by violass
lancio xampp poi clicco su tutti i bottoni start e mi compare la schermata 1 in foto.

poi clicco su admin di apache e mi appare la schermata2 in foto.
da qui non so come accedere a ls

Fatemi sapere...grazie!



Attachments:

Please Log in to join the conversation.

More
9 months 3 weeks ago #135406 by lfanfoni
che domanda è?
a vedere gli screenshoot hai tutto l'ambiente a posto (intendo WAMP). Se hai già messo gli script di ls su una sottocartella di htdocs, dovresti già andare al setup con http://localhost/limesurvey/admin/

Please Log in to join the conversation.

More
9 months 3 weeks ago #135409 by violass
Ecco, mi può spiegare meglio questo ultimo passaggio?
Perché se digito quell'indirizzo sul browser non trova la pagina..

Please Log in to join the conversation.

More
9 months 3 weeks ago #135410 by lfanfoni
Sul manuale c'è anche la pagina di italiano, che spiega molto meglio di come potrei spiegarti io, come installare LimeSurvey

Please Log in to join the conversation.

More
9 months 3 weeks ago #135412 by violass
Ho seguito anche quello ma non sono riusciti ad arrivare a ls
Mi può dire di preciso cosa fare quando arrivò alla seconda schermata?
Grazie

Please Log in to join the conversation.

More
9 months 2 weeks ago #135489 by lfanfoni
Tu fai riferimento a un post scritto più di 3 anni fa...sono cambiate sia le versioni dell'XAMPP che del limesurvey.
Per prima cosa devi verificare che XAMPP ti funzioni bene sul tuo pc. Per funzionare bene significa che se digiti sul browser "localhost" ti dovrebbe apparire la home page di XAMPP. Per seconda cosa devi essere sicuro che ti funzioni bene il MySql. Per funzionare bene significa che se digiti sul browser "localhost/phpmyadmin", oppure se clicki il comando dalla home page di cui sopra (XAMPP), dovresti accedere al db MySql. Per terza cosa creati una cartella sotto htdocs e mettici un qualsiasi html o php. Se con il browser raggiungi correttamente "localhost/miacartella/miofile.htm" significa che dal tuo pc stai simulando correttamente un webserver. Dovresti anche verificare se il compilatore php funziona a dovere, ma suppergiù dovresti essere pronto per installarti il limesurvey secondo le istruzioni del manuale. Ovviamente se hai una situazione sporca, ricomincia da capo disinstallando prima l'XAMPP (Apache, Mysql, Php) eppoi rimuovendo le cartelle.

Please Log in to join the conversation.

More
9 months 2 weeks ago #135531 by violass
Ok grazie
come vede dalle foto che ho allegato al post precedente anche sql mi funziona.
Quello che vorrei sapere è come si fa a creare una cartella sotto htdocs, banalmente vorrei sapere dove cliccare per fare questi ultimi passaggi quando sono sul phpmyadmin

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form