Questionario si chiude pur non essendo terminato

More
2 weeks 5 days ago - 2 weeks 5 days ago #189381 by italociro
Ciao a tutti,
ho un problema che mi sta assillando: ho fatto una Survey con domddne obbligatorie che funzionano alla grande ma capita spesso che l'utente che rientra in un secondo momento attraverso il suo link viene rinviato dal sistema all'ultima pagina finale in cui si conclude la survey. Morale: l'utente salta le domande e conclude la Survey.
Ho provato di tutto ma nulla, sono costretto a riaprire manualmente le survey sperando che il problema non si verifichi un'altra volta.
ps. Versione 3.12.2+180625
Soluzioni?
Last edit: 2 weeks 5 days ago by italociro.

Please Log in or Create an account to join the conversation.

LimeSurvey Partners
More
2 weeks 5 days ago #189383 by lfanfoni
Non dovresti aver perso le risposte già fornite, dovrebbe accadere soltanto che il partecipante rientra nel questionario all'ultima pagina compilata, cioè l'ultima. Ma le risposte (obbligatorie le ha già date, per vederle è sufficente andare indietro nelle pagine del questionario).
Puoi impedire che una volta inviato il questionario, il partecipante rientri a modificare le domande. Questa opzione la trovi sulle impostationi dei partecipanti.
Se c'è proprio necessità che un partecipante rientri nel suo questionario, a quel punto puoi andare sulla sua risposta e settare la risposta come parziale, poi nel pannello del partecipante manualmente modifichi la data di invio a N e imposti a 1 la pagina di ultimo salvataggio.

Aiutaci a far crescere la comunità italiana di LimeSurvey: vai sul forum Italiano per richieste e soluzioni citando sempre la versione usata, non scrivere in privato, suggerisci modifiche o nuove traduzioni - www.limesurvey.org/forum/italian-forum/118441

Please Log in or Create an account to join the conversation.

More
2 weeks 5 days ago #189384 by italociro
Grazie, prov ad essere più chiaro.
In effetti le risposte non le perdo.
Facciamo un esempio: l'utente entra compila qualche domanda e poi si stufa e spegne tutto. Rientra successivamente ma a questo punto cliccando sul suo link viene ricondotto direttamente alla pagina finale e non può più tornare indietro.
Io da sistema vedo il questionario completo ma senza che siano state compilate tutte le domande.
Credo proprio sia un bug.

Please Log in or Create an account to join the conversation.

More
2 weeks 5 days ago #189393 by lfanfoni
Non credo che sia un bug, non mi è mai capitato. Devi riuscire a replicare l'errore, per dire che è un bug. Intanto metti visualizzato il pulsante "Indietro", e poi verifica, analizzando le risposte definitive, se veramente ci sono dati obbligatori non inseriti

Aiutaci a far crescere la comunità italiana di LimeSurvey: vai sul forum Italiano per richieste e soluzioni citando sempre la versione usata, non scrivere in privato, suggerisci modifiche o nuove traduzioni - www.limesurvey.org/forum/italian-forum/118441

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!