Mancata associazione Provincia/Comune

More
3 months 1 day ago #164274 by lfanfoni
lfanfoni replied the topic: Mancata associazione Provincia/Comune
Su JavaScript non me la cavo troppo bene. Lascio la palla a chi se la cava meglio di me.
Continuo comunque a pensare che le dropdown combinate su una stessa domanda doppia scala siano decisamente meglio di due domande dropdown combinate
The following user(s) said Thank You: Frasca

Please Log in or Create an account to join the conversation.

More
3 months 1 day ago #164289 by oreslas
oreslas replied the topic: Mancata associazione Provincia/Comune
Ciao Frasca,
ho appena postato una gruppo di domande per LS con la soluzione al tuo problema.
Puoi scaricarlo da qui
www.limesurvey.org/forum/italian-forum/1...-due-dropdown#164288

Please Log in or Create an account to join the conversation.

More
3 months 1 day ago #164294 by Frasca
Frasca replied the topic: Mancata associazione Provincia/Comune
Grazie mille ma non riesco ad aprirlo e quindi anche importarlo perchè in formato .lsg, soluzioni?

Please Log in or Create an account to join the conversation.

More
3 days 3 hours ago #168888 by seccalisca
seccalisca replied the topic: Mancata associazione Provincia/Comune
Buongiorno a tutti e grazie per tutto l'aiuto che potrete darmi: è una settimana che provo a inserire questo script ma ogni volta ho un problema diverso. Ho cercato di leggere tutto, e ho fatto varie prove. Ora visti i miei (evidenti) limiti e visto che la data di scadenza della mia survey si avvicina sempre più vi chiedo un ultimo aiuto.
Andiamo per ordine:
  • la mia versione di Limesurvey è 2.05+ Build 141229 (a proposito aggiornamenti alle release più recenti li consigliate?);
  • ho utilizzato lo script fornito dall'ottimo lfanfoni ( questo qui ) e funziona perfettamente, MA
  • all'inizio il file dei comuni era troppo grande e non lo caricava
  • ho contattato l'amministratore e abbiamo risolto
  • adesso il caricamento va a buon fine ma quando passo alla domanda lo schermo rimane bianco (uso Firefox)
  • allora ho provato a creare una domanda ex novo con l'array doppia scala seguendo le istruzioni che lfanfoni da più avanti con il solo script e con un paio di dati di prova inseriti da me e tutto funziona perfettamente

Quindi ora ho due ipotesi:
  • in mezzo a questo mare di prove io mi sono incartato da qualche parte (ogni consiglio è bene accetto);
  • posso provare a caricare la tabella dei comuni DOPO aver creato la domanda (ma in questo caso come faccio con i codici che devono "legarsi" fra loro per far funzionare il filtro?)

Grazie fin d'ora

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!