Do I need a Windows Server?

More
2 years 11 months ago #114478 by iankmca
iankmca created the topic: Do I need a Windows Server?
Hostgator says that the reason the Lime script isn't working is that it needs a Windows server, while I am using an Apache server.
The error message says that their version of PHP needs to be updated, but they seem to be unwilling to do it.
Do I just have to give up on using the script?

Please Log in to join the conversation.

More
2 years 11 months ago #114479 by Ben_V
Ben_V replied the topic: Do I need a Windows Server?
Wich script?installation script?

Obviously, LS works on apache server... depending on the available php version and some other common requierements ( see doc )

I can't believe that hostgator sucks in running limesurvey (recent releases) with apache :huh:

Benoît

EM Variables => bit.ly/1TKQyNu | EM Roadmap => bit.ly/1UTrOB4
Last Releases => 2.6x.x goo.gl/ztWfIV | 2.06/2.6.x => bit.ly/1Qv44A1
Demo Surveys => goo.gl/HuR6Xe (already included in /docs/demosurveys)
The following user(s) said Thank You: iankmca

Please Log in to join the conversation.

More
2 years 11 months ago #114480 by holch
holch replied the topic: Do I need a Windows Server?
After this response I would give up Hostgator, because the obviously don't know what they are doing.

Limesurvey runs mostly on Linux and Apache environments. It ALSO can be run on a Windows Server, but I would actually not recommend it.

So the problem is rather with your hoster. There are so many others out there, that are actually better than Hostgator, that I would switch my host, especially after this fail.

By the way: It is even worse. Windows server and Apache server do not exclude each other. You can run a Apache webserver on a Windows server. They don't exclude each other. You must have gotten this response from a Level 1 support member with really no clue of computers... ;-)

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
2 years 11 months ago #114483 by Mazi
Mazi replied the topic: Do I need a Windows Server?
What a poor support response...

From my >8 years of Limesurvey experience I can conclude that a LAMP system with Apache is the best configuration when running Limesurvey.
When using a Windows server and IIS there are some issues which can show up at certain configurations.

That's why the Limesurvey optimized hosting I am offering at www.limesurvey-consulting.com/hosting/ also runs on a Linux server with Apache.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
2 years 11 months ago #114502 by iankmca
iankmca replied the topic: Do I need a Windows Server?
Thanks. They seem to gave found a support team member who knows what he is talking about. He says it limesurvey should work on the apache account that I already have, and wants the URL of the script "so we can take a look at it and make any necessary permissions changes?"

Hopefully it will all be sorted out some time next week. If I visit
presentationhowto.com/limesurvey/ I get the error message. I'm pretty sure I set all the permissions to 777.

Please Log in to join the conversation.

More
2 years 11 months ago - 2 years 11 months ago #114504 by GLComputing
GLComputing replied the topic: Do I need a Windows Server?
Have you checked the PHP version on the system?

You can select up to 5.3 with Windows Shared and 5.4 with Windows Dedicated according to:
support.hostgator.com/articles/what-vers...of-php-are-you-using

The page has links to enable the version you want

[Edit: misread the question: The non-Win servers also listed :ohmy: ]
Last Edit: 2 years 11 months ago by GLComputing. Reason: Clarified that also applies to non-win

Please Log in to join the conversation.

More
2 years 11 months ago #114507 by holch
holch replied the topic: Do I need a Windows Server?
Well, the error message is pretty clear, isn't it?

"This script can only be run on PHP version 5.3.0 or later! Your version: 5.2.17"

Limesurvey requires PHP version 5.3.0 and your server only has 5.2.17 installed. So either you upgrade the PHP version on your server or you move to a different server.

By the way: the lastest version is 5.6, so you can imagine how old this PHP version is.

If you look here, your PHP versions seems not even get any security updates anymore since 6 January 2011. That is almost 4 years! Time to upgrade, I would say.

en.wikipedia.org/wiki/PHP

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
2 years 11 months ago #114544 by iankmca
iankmca replied the topic: Do I need a Windows Server?
I agree that the error message is obvious. I hope Hostgator will soon agree also.

It's interesting that version 5.6 is the latest.

I'll let you know when Hostgator support finally get round to replying.

Please Log in to join the conversation.

More
2 years 11 months ago #114615 by DenisChenu
DenisChenu replied the topic: Do I need a Windows Server?

GLComputing wrote: ....
[Edit: misread the question: The non-Win servers also listed :ohmy: ]

In this page:

PHP 5.2 is deprecated software and is no longer being updated by the PHP development team. As such, we recommend that you prepare your scripts for PHP 5.3, 5.4 or 5.5.

Then you can have 5.3 with hostgator.

Surely some manual settings to set ot to 5.2.

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in to join the conversation.

More
2 years 11 months ago #114679 by iankmca
iankmca replied the topic: Do I need a Windows Server?
The problem has been solved - eventually. Hostgator says that I could have fixed it myself in cPanel. They say

Thank you for provide the location of the script so that we can review the error you were receiving. I see that this was simply requiring a different PHP version. Your hosting account can use multiple PHP versions and you can even use a different version for a specific site or directory. This can be managed through the "PHP Configuration" page found in cPanel under the "Advanced" section.

So they've finally discovered that a different PHP version was needed...That's what I told them when I opened the support ticket!

Thanks for all your help. I'll close this thread now if I can find the right button to click.

Ian McAllister

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now