Upgrade from 1.92+ to 2.05+ fail during dbupdate with the error message...

More
3 years 2 months ago #113372 by kettner
kettner created the topic: Upgrade from 1.92+ to 2.05+ fail during dbupdate with the error message...
Hello,

I have just been performing manual upgrade from 1.92+ to 2.05+. I think I still get error message that should not appear in the latest release. I have read the Bugtracker here bugs.limesurvey.org/view.php?id=7115 where exactly the problem should have been resolved. However I am not sure, as that bug resolution belongs to 2.00 version. Is the patch in the latest 2.05+ still applied?

I get exactly this message during db update:
CDbCommand failed to execute the SQL statement: SQLSTATE[25P02]: In failed sql transaction: 7 ERROR: current transaction is aborted, commands ignored until end of transaction block

I run LimeSurvey on PostgreSQL 9.1.14, Linux Ubuntu.

What shold I do to fix this problem?

Many thanks in advance.

Please Log in to join the conversation.

More
3 years 2 months ago #113401 by kettner
kettner replied the topic: Upgrade from 1.92+ to 2.05+ fail during dbupdate with the error message...
Well, I have tried to install upgrade via 2.00 package first 1019-limesurvey200plus-build131206-tar-gz

But still getting the same message.

Here is what the pgsql logs say:
2014-10-13 16:10:07 CEST ERROR: table "lime_survey_url_parameters" does not exist
2014-10-13 16:10:07 CEST STATEMENT: DROP TABLE "lime_survey_url_parameters"
2014-10-13 16:10:07 CEST ERROR: current transaction is aborted, commands ignored until end of transaction block
2014-10-13 16:10:07 CEST STATEMENT: CREATE TABLE "lime_survey_url_parameters" (
"id" serial NOT NULL PRIMARY KEY,
"sid" integer NOT NULL,
"parameter" character varying(50) NOT NULL,
"targetqid" integer,
"targetsqid" integer
)

Hm, I cannot find any existing help to this issue. Maybe it is time to consult our db specialist...

Please Log in to join the conversation.

More
3 years 2 months ago #113417 by kettner
kettner replied the topic: Upgrade from 1.92+ to 2.05+ fail during dbupdate with the error message...
Well, after consultations with my colleague a db specialist, the solution to the problem was relatively easy.
The update script was simply trying to drop a couple of tables that were not present. After creating the tables manually according to the script, the update script went smoothly. There were however some other minor errors in the log file, but nothing severe.

Now the 2.05+ version seems working properly just at first sight...

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!