INTERNAL SERVER ERROR: Property update.updaterversion is not defined

More
2 years 9 months ago - 2 years 9 months ago #110020 by Sweden
Hi,

I am trying to update from Version 2.00+ (131206) to 2.05+ (140612). I get this error right after I click the "Use ComfortUpdate" button:

Internal Server Error
Property "update.updaterversion" is not defined.


I have tried to close my browser and my computer (low memory can cause weird problems...) but that doesn't help. I normally use the ComfortUpdate without any problems so what can be wrong?
Last Edit: 2 years 9 months ago by Sweden.
The following user(s) said Thank You: despeaux

Please Log in to join the conversation.

More
2 years 9 months ago #110072 by despeaux
I, too, am having this issue when I try to use the one click update.

Screenshot attached.
Attachments:

Please Log in to join the conversation.

More
2 years 9 months ago #110075 by c_schmitz
Please use this patch here: bugs.limesurvey.org/view.php?id=9064

Best regards

Carsten Schmitz
LimeSurvey project leader

Please Log in to join the conversation.

More
2 years 9 months ago - 2 years 9 months ago #110186 by Sweden
Thank you very much. It works now but I got a couple of "An non-recoverable error happened during the update. Error details:

CDbCommand failed to execute the SQL statement: SQLSTATE[42S01]: Base table or view already exists: 1050 Table '_plugins' already exists.


Also got the same error for "_plugin_settings" and "_permissions" so I deleted all three tables - hope that is okay :unsure:
Last Edit: 2 years 9 months ago by Sweden.

Please Log in to join the conversation.