Showing Pie-Chart with MSSql Survey

More
3 years 4 months ago #108195 by SvenF
SvenF created the topic: Showing Pie-Chart with MSSql Survey
I have problems, using Pie-Charts within my statics. When I select it, a message popup occurs: "An error occured! Please reload the page!" This is with MSSql-Database.

Using the same survey (at the same webserver) with MySQL Database, the same chart can be switched to pie and back.

Any idea, what's the reason? The survey has to run with MSSQL.

Please Log in to join the conversation.

More
3 years 4 months ago #108316 by DenisChenu
DenisChenu replied the topic: Showing Pie-Chart with MSSql Survey
Maybe a MSSQL server specific bug.

What is your LimeSUrvey version ?

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in to join the conversation.

More
3 years 4 months ago #108317 by SvenF
SvenF replied the topic: Showing Pie-Chart with MSSql Survey
My version is: Version 2.05+ Build 140320

Please Log in to join the conversation.

More
3 years 4 months ago #108335 by DenisChenu
DenisChenu replied the topic: Showing Pie-Chart with MSSql Survey
Can you update to last version (auto update can work)
Try again,
If it don't work :
- Set config to 2
- Look at console (if you have a good browser) and pit the code shown in console.
- Report Bug in our bug tracker

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in to join the conversation.

More
3 years 4 months ago #108374 by SvenF
SvenF replied the topic: Showing Pie-Chart with MSSql Survey
Same with latest version.

Made a bug report [09025]

Please Log in to join the conversation.

More
1 year 6 months ago #132444 by simogeo
simogeo replied the topic: Showing Pie-Chart with MSSql Survey
Hi,

I experienced the same issue here using MySQL Server on LS version : Version 2.06+ Build 160123

When switching from diagramm to pie chart I get the error message and then, I'm note able to display the report with charts : I get a blank page.... It is ok with no charts.

I guess charts preferences are stored somewhere. Is there a way to reset them, so I can access my stats report with graph again ?

Is there an error log accessible ?

I've seen this : bugs.limesurvey.org/view.php?id=9025 but it is supposed to be fix. So what can I do ?
Thanks for your help.

Please Log in to join the conversation.

More
1 year 6 months ago - 1 year 6 months ago #132462 by simogeo
simogeo replied the topic: Showing Pie-Chart with MSSql Survey
Investigating a bit, I put debug mode on config file and have seen that it triggers a fatal error. See below :
Fatal error: Call to a member function gT() on string in /home/myfolder/www/enquetes/application/helpers/admin/statistics_helper.php on line 239

For information, I reported the bug here : bugs.limesurvey.org/view.php?id=10641
Last Edit: 1 year 6 months ago by simogeo.

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now