display token and get an 500 error

More
3 years 4 months ago #107216 by mrli999
mrli999 created the topic: display token and get an 500 error
In my web site, I can't display token. When using chrome, I got the following error


www.example.com/survey/index.php?r=admin...on/surveyid/SURVEYID

Failed to load resource: the server responded with a status of 500 (Internal Server Error) . And also
vent.returnValue is deprecated. Please use the standard event.preventDefault() instead.

How can I resolve this problem? Thanks.

Please Log in to join the conversation.

More
3 years 4 months ago #107227 by DenisChenu
DenisChenu replied the topic: display token and get an 500 error
Hi,

Really good idea to teke the link, but please, can you activate debug=2 in application/config.config.php and put the html file answer.

And : your LimeSurvey version please.

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .
The following user(s) said Thank You: mrli999

Please Log in to join the conversation.

More
3 years 4 months ago #107239 by mrli999
mrli999 replied the topic: display token and get an 500 error
Version 2.05+ Build 140320

[17:20:19.250][trace][system.db.ar.CActiveRecord] Plugin.findAllByAttributes()
[17:20:19.251][trace][system.db.CDbConnection] Opening DB connection
[17:20:19.266][trace][system.db.CDbCommand] Querying SQL: SELECT * FROM `lime_plugins` `t` WHERE `t`.`active`=:yp0. Bound with :yp0=1
[17:20:19.276][trace][system.db.ar.CActiveRecord] SettingGlobal.findAll()
[17:20:19.276][trace][system.db.CDbCommand] Querying SQL: SELECT * FROM `lime_settings_global` `t`
[17:20:19.336][trace][system.db.ar.CActiveRecord] Survey.findByPk()
[17:20:19.336][trace][system.db.CDbCommand] Querying SQL: SELECT * FROM `lime_surveys` `t` WHERE `t`.`sid`=862167 LIMIT 1
[17:20:19.339][trace][system.db.ar.CActiveRecord] SurveyLanguageSetting.findByPk()
[17:20:19.343][trace][system.db.CDbCommand] Querying SQL: SELECT `t`.`surveyls_survey_id` AS `t0_c0`, `t`.`surveyls_language` AS `t0_c1`, `t`.`surveyls_title` AS `t0_c2`, `t`.`surveyls_description` AS `t0_c3`, `t`.`surveyls_welcometext` AS `t0_c4`, `t`.`surveyls_endtext` AS `t0_c5`, `t`.`surveyls_url` AS `t0_c6`, `t`.`surveyls_urldescription` AS `t0_c7`, `t`.`surveyls_email_invite_subj` AS `t0_c8`, `t`.`surveyls_email_invite` AS `t0_c9`, `t`.`surveyls_email_remind_subj` AS `t0_c10`, `t`.`surveyls_email_remind` AS `t0_c11`, `t`.`surveyls_email_register_subj` AS `t0_c12`, `t`.`surveyls_email_register` AS `t0_c13`, `t`.`surveyls_email_confirm_subj` AS `t0_c14`, `t`.`surveyls_email_confirm` AS `t0_c15`, `t`.`surveyls_dateformat` AS `t0_c16`, `t`.`surveyls_attributecaptions` AS `t0_c17`, `t`.`email_admin_notification_subj` AS `t0_c18`, `t`.`email_admin_notification` AS `t0_c19`, `t`.`email_admin_responses_subj` AS `t0_c20`, `t`.`email_admin_responses` AS `t0_c21`, `t`.`surveyls_numberformat` AS `t0_c22`, `t`.`attachments` AS `t0_c23`, `survey`.`sid` AS `t1_c0`, `survey`.`owner_id` AS `t1_c1`, `survey`.`admin` AS `t1_c2`, `survey`.`active` AS `t1_c3`, `survey`.`expires` AS `t1_c4`, `survey`.`startdate` AS `t1_c5`, `survey`.`adminemail` AS `t1_c6`, `survey`.`anonymized` AS `t1_c7`, `survey`.`faxto` AS `t1_c8`, `survey`.`format` AS `t1_c9`, `survey`.`savetimings` AS `t1_c10`, `survey`.`template` AS `t1_c11`, `survey`.`language` AS `t1_c12`, `survey`.`additional_languages` AS `t1_c13`, `survey`.`datestamp` AS `t1_c14`, `survey`.`usecookie` AS `t1_c15`, `survey`.`allowregister` AS `t1_c16`, `survey`.`allowsave` AS `t1_c17`, `survey`.`autonumber_start` AS `t1_c18`, `survey`.`autoredirect` AS `t1_c19`, `survey`.`allowprev` AS `t1_c20`, `survey`.`printanswers` AS `t1_c21`, `survey`.`ipaddr` AS `t1_c22`, `survey`.`refurl` AS `t1_c23`, `survey`.`datecreated` AS `t1_c24`, `survey`.`publicstatistics` AS `t1_c25`, `survey`.`publicgraphs` AS `t1_c26`, `survey`.`listpublic` AS `t1_c27`, `survey`.`htmlemail` AS `t1_c28`, `survey`.`sendconfirmation` AS `t1_c29`, `survey`.`tokenanswerspersistence` AS `t1_c30`, `survey`.`assessments` AS `t1_c31`, `survey`.`usecaptcha` AS `t1_c32`, `survey`.`usetokens` AS `t1_c33`, `survey`.`bounce_email` AS `t1_c34`, `survey`.`attributedescriptions` AS `t1_c35`, `survey`.`emailresponseto` AS `t1_c36`, `survey`.`emailnotificationto` AS `t1_c37`, `survey`.`tokenlength` AS `t1_c38`, `survey`.`showxquestions` AS `t1_c39`, `survey`.`showgroupinfo` AS `t1_c40`, `survey`.`shownoanswer` AS `t1_c41`, `survey`.`showqnumcode` AS `t1_c42`, `survey`.`bouncetime` AS `t1_c43`, `survey`.`bounceprocessing` AS `t1_c44`, `survey`.`bounceaccounttype` AS `t1_c45`, `survey`.`bounceaccounthost` AS `t1_c46`, `survey`.`bounceaccountpass` AS `t1_c47`, `survey`.`bounceaccountencryption` AS `t1_c48`, `survey`.`bounceaccountuser` AS `t1_c49`, `survey`.`showwelcome` AS `t1_c50`, `survey`.`showprogress` AS `t1_c51`, `survey`.`questionindex` AS `t1_c52`, `survey`.`navigationdelay` AS `t1_c53`, `survey`.`nokeyboard` AS `t1_c54`, `survey`.`alloweditaftercompletion` AS `t1_c55`, `survey`.`googleanalyticsstyle` AS `t1_c56`, `survey`.`googleanalyticsapikey` AS `t1_c57` FROM `lime_surveys_languagesettings` `t` LEFT OUTER JOIN `lime_surveys` `survey` ON (t.surveyls_survey_id = survey.sid) WHERE (`t`.`surveyls_survey_id`=862167 AND `t`.`surveyls_language`='zh-Hans')
[17:20:19.344][trace][system.db.CDbCommand] Querying SQL: SHOW TABLES
[17:20:19.350][trace][system.db.ar.CActiveRecord] Token_862167.count()
[17:20:19.350][trace][system.db.CDbCommand] Querying SQL: SELECT COUNT(*) FROM `lime_tokens_862167` `t`
[17:20:19.355][trace][system.db.ar.CActiveRecord] Permission.findByAttributes()
[17:20:19.355][trace][system.db.CDbCommand] Querying SQL: SELECT * FROM `lime_permissions` `t` WHERE `t`.`entity_id`=:yp0 AND `t`.`entity`=:yp1 AND `t`.`uid`=:yp2 AND `t`.`permission`=:yp3 LIMIT 1. Bound with :yp0=0, :yp1='global', :yp2=1, :yp3='superadmin'
event.returnValue is deprecated. Please use the standard event.preventDefault() instead.


Is this what you need? Many many thanks.

Please Log in to join the conversation.

More
3 years 4 months ago - 3 years 4 months ago #107273 by DenisChenu
DenisChenu replied the topic: display token and get an 500 error
Hi,

Seem you activate debug sql, but not debug ?
// Use the following config variable to set modified optional settings copied from config-defaults.php
    'config'=>array(
        // debug: Set this to 1 if you are looking for errors. If you still get no errors after enabling this
        // then please check your error-logs - either in your hosting provider admin panel or in some /logs directory
        // on your webspace.
        // LimeSurvey developers: Set this to 2 to additionally display STRICT PHP error messages and get full access to standard templates
        'debug'=>1,
        'debugsql'=>0 // Set this to 1 to enanble sql logging, only active when debug = 2
    )

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .
Last Edit: 3 years 4 months ago by DenisChenu.
The following user(s) said Thank You: mrli999

Please Log in to join the conversation.

More
3 years 4 months ago #107329 by mrli999
mrli999 replied the topic: display token and get an 500 error
I set debug to 1 as the following:
'debug'=>1,
'debugsql'=>0

Still can't display token, but didn't see any error. Also I search error_log on my server, and didn't find any new error_log.


Is the following steps right?
1. set debug to 1 and debugsql to 0.
2. upload the config.php to application/config
3. display token
4. press F12
5. get related information from console.

Many many thanks.

Please Log in to join the conversation.

More
3 years 4 months ago #107330 by mrli999
mrli999 replied the topic: display token and get an 500 error
Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 89 bytes) in survey/framework/db/ar/CActiveRecord.php on line 1861

I tried again, and got the above error.

Please Log in to join the conversation.

Did you already participate in our customer survey?

Don't miss your chance for great prices.

Please click here to participate:

Start now

Start now!

Just create your account and start using Limesurvey today.

Register now