500 error: Undefined index: config

More
3 years 2 months ago - 3 years 2 months ago #105698 by hvalentim
hvalentim created the topic: 500 error: Undefined index: config
Tried updating this morning to most recent 2.05+ version and ended up stuck with an error message while logs were filled with these:

[error] FastCGI: server "/usr/lib/cgi-bin/php5-fcgi" stderr: PHP message: PHP Notice: Undefined index: config in /srv/www/domain.com/public_html/site/application/core/LSYii_Application.php on line 59
[error]FastCGI: server "/usr/lib/cgi-bin/php5-fcgi" stderr: PHP message: PHP Notice: ob_clean(): failed to delete buffer zlib output compression in /srv/www/domain.com/public_html/site/framework/base/CErrorHandler.php on line 110

I am using PHP 5.3.10-1ubuntu3.9 if that helps.

Previous 2.05+ was working like a charm.
Last Edit: 3 years 2 months ago by hvalentim. Reason: grammar and details

Please Log in to join the conversation.

More
3 years 1 month ago #105792 by DenisChenu
DenisChenu replied the topic: 500 error: Undefined index: config
Hi,

1st : you have set php_value error_reporting E_ALL somewhere in your virtula host, or in your php.ini.
2nd : you remove or comment some line in your application/config/config.php
Default config.php have this line at eneds:
	'config'=>array(
	// debug: Set this to 1 if you are looking for errors. If you still get no errors after enabling this
	// then please check your error-logs - either in your hosting provider admin panel or in some /logs directory
	// on your webspace.
	// LimeSurvey developers: Set this to 2 to additionally display STRICT PHP error messages and get full access to standard templates
		'debug'=>0,
		'debugsql'=>0 // Set this to 1 to enanble sql logging, only active when debug = 2
	)
But, ith the last version, you don't have error even with this configuration.

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in to join the conversation.

More
3 years 1 month ago #105802 by hvalentim
hvalentim replied the topic: 500 error: Undefined index: config
Thanks a lot for your fix.

I was using an old config.php (installation originally dates back to version 1.8 or 1.9...) and that portion was missing.

Everything is working fine now.

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now