Check out the LimeSurvey source code on GitHub!

Issue with Results Export

More
3 years 2 weeks ago #104824 by LloydW
Hi
I have a large number of questions (around 1023 columns of data). Limesurvey is working fine and I can see all the entered data using the data analysis tools built in, and if I export the VV file.

If I export as a CSV, HTML or similar, it truncates the columns at 990. I've tried multiple options,(and yes all the questions are selected), and on versions from 2.05 v140116 to v140204 but all stop at the same point.

Any ideas?

Please Log in to join the conversation.

More
3 years 2 weeks ago #104829 by DenisChenu
Hi,

Can you active debug mode in your application/config/config.php file ?
You see all the column in phpMyAdmin or another DB tool ?
If you select only last columns: it work ?

Maybe time to report the bug (but think some DB are limited to 1024 column).

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

More
3 years 2 weeks ago #104841 by LloydW
Hi Denis

I have switched the active debug bit to 1, but nothing returned. Is there a log file I should be checking?

The columns are visible with all the Limesurvey Statistical Analysis or display responses, and as I indicated successfully export in the VV file.

I was also able to export just the last 100 columns without problem.

Seems to be only when I export to application (CSV, HTML or similar). Seems to be about the *number* of columns.

Let me know if you would like a copy of the database with a dummy entry (offline perhaps) to validate the problem, then I could log the bug.

Lloyd.

Please Log in to join the conversation.

More
3 years 2 weeks ago #104877 by lowprofile
in v1.92 I had a user with a question code called time (or time something) causing a similar problem, whats the question code name for column 990?

Please Log in to join the conversation.

More
3 years 2 weeks ago #104879 by LloydW
Hi lowprofile,

The question is:
g3q7(sq12) Physiologic Monitoring Syst. (BP, ECG, SpO<sub>2</sub>, Temp)

Its an ARRAY question that it breaks between SQ0006 & SQ0007 (the x scale) so I doubt it. Nothing between those two that hadn't appeared before causing a problem.

Please Log in to join the conversation.

More
3 years 2 weeks ago #104890 by DenisChenu
Hi,

Think the best is to :
- Export LSA file
- Put a private bug report and upload this lsa file (private mean only dev have access to your LSA file).

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

More
3 years 1 week ago #104941 by LloydW
Done - bug report 8701.
The following user(s) said Thank You: DenisChenu

Please Log in to join the conversation.

More
3 years 1 week ago #105021 by LloydW
Update on this. After submitting the bug report Carsten flagged that the issue was php related and because it wasn't obvious to me anywhere these settings :dry: I thought I'd offer them for others.

Generally you need your php.ini file to have:

max_input_vars=2000 - or beyond the number of questions in the file (default is 1000).

That was done, but wasn't the problem.
If you have the Suhosin extension as part of your server (phpinfo will tell you), you ALSO need:

suhosin.post.max_vars=2000
suhosin.request.max_vars=2000
(or beyond the max number of the questions).

In my case to resolve this issue, it was the last value that mattered. Once that was set above my 1048 questions the export function worked properly.

Hope that helps people. Lloyd. :)

Please Log in to join the conversation.

More
3 years 1 week ago #105024 by holch
Maybe you could add this information to the manual? It is a wiki and everyone can add to it, because here in the forum the information might get lost over time, because after a while the forum is "cleaned up" and old posts get deleted.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
3 years 1 week ago #105031 by DenisChenu

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

More
3 years 1 week ago #105077 by LloydW
I'd agree with your suggestion. Unfortunately the Manual wiki either doesn't want to let me log in or won't give me 'user' access so I can't edit the wiki. Perhaps one of you two could add my comment? Ta, Lloyd.

Please Log in to join the conversation.

More
3 years 1 week ago #105082 by DenisChenu

LloydW wrote: I'd agree with your suggestion. Unfortunately the Manual wiki either doesn't want to let me log in or won't give me 'user' access so I can't edit the wiki. Perhaps one of you two could add my comment? Ta, Lloyd.

Strange , sometimes you need to reset your password on forum, then you have the same user/pass for wiki.

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form