mod_security issue

More
3 years 9 months ago #104396 by oldgit
oldgit created the topic: mod_security issue
I have just been creating a survey and have noticed that it has generated a large number of notifications from mod_security on my server. Luckily, I have my IP address whitelisted so I am not locked out. I am using the latest update of LimeSurvey and a pretty standard rule set on mod_sec.

One example of the notice follows...
[Sun Feb 02 14:32:19 2014] [error] [client xxx.xxx.xxx.xxx] ModSecurity: Access denied with code 406 (phase 2). Pattern match "(?:\\\\b(?:(?:type\\\\b\\\\W*?\\\\b(?:text\\\\b\\\\W*?\\\\b(?:j(?:ava)?|ecma|vb)|application\\\\b\\\\W*?\\\\bx-(?:java|vb))script|c(?:opyparentfolder|reatetextrange)|get(?:special|parent)folder|iframe\\\\b.{0,100}?\\\\bsrc)\\\\b|on(?:(?:mo(?:use(?:o(?:ver|ut)|down|move|up)|ve)| ..." at REQUEST_FILENAME. [file "/usr/local/apache/conf/modsec2.user.conf"] [line "117"] [id "1234123404"] [msg "Cross-site Scripting (XSS) Attack"] [data ".cookie"] [severity "CRITICAL"] [tag "WEB_ATTACK/XSS"] [hostname "www.my-domain.net"] [uri "/third_party/jquery-cookie/jquery.cookie.js"] [unique_id "Uu5W89XlWkcAAFrjdzsAAAAI"]

Please Log in to join the conversation.

More
3 years 9 months ago #104483 by DenisChenu
DenisChenu replied the topic: mod_security issue
Hi,

Did you use "Adanced setting"/ timer settings ?
If yes: can you deactivate it and test again ?

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in to join the conversation.

More
3 years 9 months ago #104508 by oldgit
oldgit replied the topic: mod_security issue

DenisChenu wrote: Hi,

Did you use "Adanced setting"/ timer settings ?

Denis


Thanks, Denis, for your response. I'm not sure where I would find these settings. Are they in mod_sec or LimeSurvey's admin area? Anyway, I have disabled that rule for this subdomain as I was getting just too many false positives.

Thanks again...

Please Log in to join the conversation.

More
3 years 9 months ago #104612 by DenisChenu
DenisChenu replied the topic: mod_security issue
Hi,

It's because i don't think we use /third_party/jquery-cookie/jquery.cookie.js in all survey.

Just need to find : when we use it and if it's with the last Yii version.

Maybe you can put a bug rem=port with a "really" little survey ?

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in to join the conversation.

More
3 years 8 months ago - 3 years 6 months ago #106337 by jelo
jelo replied the topic: mod_security issue

DenisChenu wrote: Hi,
It's because i don't think we use /third_party/jquery-cookie/jquery.cookie.js in all survey.


This ModSecure Rule [id "1234123404"] [msg "Cross-site Scripting (XSS) Attack"] is also triggered when just using the comfort updater.

It's not a problem of Limesurvey. The corerules ( spiderlabs.github.io/owasp-modsecurity-crs/ ) are containing this rule since years.

Perhaps the regex pattern is too broad or the jquery team would need to adapt some code.

Perhaps both are right and the administrator need to choose the rules casewise.
<LocationMatch /third_party/jquery-cookie/jquery.cookie.js>
  <IfModule mod_security2.c>
    SecRuleRemoveById 1234123404
    # SecRuleEngine Off
  </IfModule>
</LocationMatch>

There are a few ways to disable rules. www.modsecurity.org/documentation/
Last Edit: 3 years 6 months ago by c_schmitz.

Please Log in to join the conversation.

More
3 years 6 months ago #109116 by elbaloo
elbaloo replied the topic: mod_security issue
I'm not sure of following... so, just to be sure:
Is this an issue with LimeSurvey, with jQuery, or just with very strict rulesets?

I'm asking because my hosting provider blocked some IPs from where I was accessing the application and after submitted a support ticket they told me that they "relaxed the rule for the domain that was causing the issue" (mine).

Please Log in to join the conversation.

More
3 years 6 months ago #109118 by jelo
jelo replied the topic: mod_security issue
The rule was disabled for your domain. My example above only disables the rule for the path of jquery. If you are on a shared hosting it is normal to disable the rule domain/account wise.

It is a false positive with this specific mod_security rule.

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!