Check out the LimeSurvey source code on GitHub!
Welcome, Guest
Username: Password:

TOPIC: White screen during Comfort Update

White screen during Comfort Update 2 years 7 months ago #103916

  • mvdct
  • mvdct's Avatar
  • Offline
  • Senior Lime
  • Posts: 41
  • Thank you received: 1
  • Karma: 0
@holch. Thank you.
So potentially upgrading to 5.3 could resolve this issue.
But might cause others in the future.
Last Edit: 2 years 7 months ago by mvdct.
The administrator has disabled public write access.

[SOLVED] White screen / HTTP 500 error during Comfort Update 2 years 7 months ago #103921

  • mvdct
  • mvdct's Avatar
  • Offline
  • Senior Lime
  • Posts: 41
  • Thank you received: 1
  • Karma: 0
Upgrading my server from PHP 5.2 to 5.3 solved this issue.
Thanks to all those who gave their advice.
Last Edit: 2 years 7 months ago by mvdct.
The administrator has disabled public write access.

[SOLVED] White screen / HTTP 500 error during Comfort Update 2 years 7 months ago #103927

  • holch
  • holch's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5095
  • Thank you received: 756
  • Karma: 227
Great to hear that it worked out for you.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

White screen during Comfort Update 2 years 7 months ago #104056

  • mdoherr
  • mdoherr's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
Dear all,
I had the same problem when using the comfort update to move from version 2.0x to the most recently available stable update. The update went all the way to step 3 (including the automatic backups) but then stopped with a white screen at step 4.
Now I can not access the installation (emmpty screen where the login window should be).
Downloaded and manually installed the latest stable version (205plus-build140116) from the Limesurvey Website following the instructions (including copying the Update folder and the Config file), however, when trying to log into the admin backend I get the same blank screen :-(
Database corrupted during update process???
Where do I find the structure and SQL database backups that are created during the comfort update process?
Any other suggestions?
THX Marcus
The administrator has disabled public write access.

[SOLVED] White screen / HTTP 500 error during Comfort Update 2 years 7 months ago #104057

  • DenisChenu
  • DenisChenu's Avatar
  • Offline
  • Moderator Lime
  • Posts: 9298
  • Thank you received: 1330
  • Karma: 386
mvdct wrote:
Upgrading my server from PHP 5.2 to 5.3 solved this issue.
Thanks to all those who gave their advice.
Assistance on LimeSurvey forum and LimeSurvey core developpement are on my free time (Say thanks ?).
A bug not reported is a bug not corrected. | Please, read the documentation | La doc en français à besoin de vous
The administrator has disabled public write access.

[SOLVED] White screen / HTTP 500 error during Comfort Update 2 years 6 months ago #104189

  • holch
  • holch's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5095
  • Thank you received: 756
  • Karma: 227
OK, so now the white screen got me as well...

I thought it would be safe to upgrade, because I have a new version of PHP running (5.4.24) and I upgraded. but now nothing works anymore, I get a white screen.

So the solution was not (only) the PHP version, I guess. Or do I have to "downgrade" my PHP version now?
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
Last Edit: 2 years 6 months ago by holch.
The administrator has disabled public write access.

[SOLVED] White screen / HTTP 500 error during Comfort Update 2 years 6 months ago #104190

  • holch
  • holch's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5095
  • Thank you received: 756
  • Karma: 227
Downgraded to 5.3.28 and there is still a white screen. My 2.05installation runs just fine. Any ideas?
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

[SOLVED] White screen / HTTP 500 error during Comfort Update 2 years 6 months ago #104193

  • mvdct
  • mvdct's Avatar
  • Offline
  • Senior Lime
  • Posts: 41
  • Thank you received: 1
  • Karma: 0
Sorry Holch,

Wish I could help you back. But not sure I have anything useful I can offer.

I'm running PHP Version 5.3.27, and as soon as I made the switch it came back online.
The administrator has disabled public write access.

[SOLVED] White screen / HTTP 500 error during Comfort Update 2 years 6 months ago #104206

  • DenisChenu
  • DenisChenu's Avatar
  • Offline
  • Moderator Lime
  • Posts: 9298
  • Thank you received: 1330
  • Karma: 386
holch wrote:
OK, so now the white screen got me as well...

I thought it would be safe to upgrade, because I have a new version of PHP running (5.4.24) and I upgraded. but now nothing works anymore, I get a white screen.

So the solution was not (only) the PHP version, I guess. Or do I have to "downgrade" my PHP version now?
Hi Holch

Can you do some test with PHP5.4 and report bug according towhat you found ?
Maybe just try a new installation (don't go at end of installation).

Remind to add this line to your index.php file:
error_reporting(E_ERROR | E_PARSE);
bugs.limesurvey.org/view.php?id=8526
Assistance on LimeSurvey forum and LimeSurvey core developpement are on my free time (Say thanks ?).
A bug not reported is a bug not corrected. | Please, read the documentation | La doc en français à besoin de vous
Last Edit: 2 years 6 months ago by DenisChenu.
The administrator has disabled public write access.

[SOLVED] White screen / HTTP 500 error during Comfort Update 2 years 6 months ago #104242

  • holch
  • holch's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5095
  • Thank you received: 756
  • Karma: 227
Hi Denis!

As I said: I had PHP 5.4 running when the problem appeared. When the white screen blocked everything, I downgraded to 5.3.x but it did not change anything.

I am not quite sure what you mean with "just try a new installation (don't go at end of installation)"

So I added the error_reporting to the index.php an here is what comes when going to the index:
Fatal error: Class 'Settings_global' not found in /home/pdb/public_html/surveys/sc3/application/helpers/globalsettings_helper.php on line 22
when
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

[SOLVED] White screen / HTTP 500 error during Comfort Update 2 years 6 months ago #104248

  • DenisChenu
  • DenisChenu's Avatar
  • Offline
  • Moderator Lime
  • Posts: 9298
  • Thank you received: 1330
  • Karma: 386
Maybe confortupdate don't get the good file here.

In this file i have : $settings = SettingGlobal::model()->findAll();

Don't really know ???
Assistance on LimeSurvey forum and LimeSurvey core developpement are on my free time (Say thanks ?).
A bug not reported is a bug not corrected. | Please, read the documentation | La doc en français à besoin de vous
The administrator has disabled public write access.

[SOLVED] White screen / HTTP 500 error during Comfort Update 2 years 6 months ago #104253

  • holch
  • holch's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5095
  • Thank you received: 756
  • Karma: 227
Problem seems to be solved. Here is what I did:

Thanks to Denis' comment I activated the debug mode with the following command added to the index.php:
error_reporting(E_ERROR | E_PARSE);

Then I received the following error message:
Fatal error: Class 'Settings_global' not found in /home/pdb/public_html/surveys/sc3/application/helpers/globalsettings_helper.php on line 22

So I did uploaded globalsettings_helper.php again, which did not help.

Then I uploaded everything from the latest version of LS 2.0 available in the download section, which is not the newest one I guess (limesurvey200plus-build131206.tar.gz).

This seems to have done the trick. So now I have the version Version 2.00+ Build 131206, but there is no update available.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.307 seconds
Imprint                   Data Protection Statement                  Revocation information and revocation form