active record class error on 205plus build 140109

More
3 years 7 months ago - 3 years 7 months ago #103385 by Steveflecha
Steveflecha created the topic: active record class error on 205plus build 140109
Hi,

I just installed LimeSurvey and it all went good. I can login without problem.
However when I try to make my first survey every time I hit the save button I get error like:
The table "{{tokens_897331}}" for active record class "Token_897331" cannot be found in the database.

Now I saw in the bug tracker there was a fix for this:
github.com/LimeSurvey/LimeSurvey/commit/...b7a84c5d86e1fffd7e16

However this fix is already in my version (I checked).

Every time I hit 'save' it creates a new survey and shows me this error (settings are saved!)
If I try to navigate to a survey via main screen (list of surveys) or via drop down box it also gives me this error.

Some details:
nginx/1.4.4
MySQL-client version: mysqlnd 5.0.8-dev - 20102224
Server version: 5.5.31-1

Please help, thanks!

Also found:
bugs.limesurvey.org/view.php?id=8527

and I replaced RegisterController.php with:
raw2.github.com/LimeSurvey/LimeSurvey/31...gisterController.php

but still same error.. didn't change anything..
Last Edit: 3 years 7 months ago by Steveflecha.

Please Log in to join the conversation.

More
3 years 7 months ago - 3 years 7 months ago #103391 by lordzoster
lordzoster replied the topic: active record class error on 205plus build 140109
I'm getting the same error while doing:
- a "Save & Close" of questions in a survey
- a "Check survey logic for current question group" in the same survey (URL: http://localhost/limesurvey/index.php/admin/expressions/sa/survey_logic_file/sid/678557/gid/1)

Environment:
LimeSurvey: Version 2.05+ Build 140109
Apache Version : Apache/2.2.14 (Unix) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l PHP/5.3.1 mod_perl/2.0.4 Perl/v5.10.1
PHP Version 5.3.1
System Darwin 13.0.0 Darwin Kernel Version 13.0.0: Thu Sep 19 22:22:27 PDT 2013; root:xnu-2422.1.72~6/RELEASE_X86_64 x86_64
MySQL: 5.1.44
Last Edit: 3 years 7 months ago by lordzoster. Reason: added new error case

Please Log in to join the conversation.

More
3 years 7 months ago #103435 by Steveflecha
Steveflecha replied the topic: active record class error on 205plus build 140109
I thought I'd submit a bug report on this today, so to document what was happening I went to the installation and did the same steps as yesterday but so far all seems to be working just fine..

I have no idea what happened as I did not change anything at all, perhaps it is a session issue or cookie issue as I just installed the system and then directly tried using it.

Please Log in to join the conversation.

Did you already participate in our customer survey?

Don't miss your chance for great prices.

Please click here to participate:

Start now

Start now!

Just create your account and start using Limesurvey today.

Register now