Check out the LimeSurvey source code on GitHub!

Install upgrade issue from from limesurvey200plus-build121204 to latest build

More
3 years 2 months ago #101760 by Label
I decided to upgrade to the lastest version of Limesurvey from my current install of limesurvey200plus-build121204 to see if that helped with my admin issue. I was running the wizard for installing/upgrading to the latest version, I entered in all my existing user/password/DB name and I received the following error message:

Internal Server Error

AdminController cannot find the requested view "/admin/authentication/login".

An internal error occurred while the Web server was processing your request. Please contact the webmaster to report this problem.


Thanks in advance.

Please Log in to join the conversation.

More
3 years 2 months ago #101812 by Anje
Also when I turned debugging on the following error message appeared:

Fatal error: Call to undefined function hash() in /srv/www/htdocs/limesurvey/application/core/UserIdentity.php on line 59 I checked the details but could not resolve the issue. Any ideas.

Please Log in to join the conversation.

More
3 years 1 month ago #101897 by DenisChenu
Hi,

Can you install php-hash ?
www.php.net/manual/en/function.hash.php

What is you php version ?

Maybe a bug in LS : we have to test if hash is OK.

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

More
3 years 1 month ago #101937 by Anje
Hi Denis,

Thanks for that I have PHP 5.2.5 installed and have checked the server and have installed php-mhash using Yast as this was the one available, I confirmed this installed in the info.php it states MHASH support enabled, MHASH API version 20060101.

I tried to login after this was installed and still could not login.

Has anyone been able to upgrade to 200 without this issue? I have looked on the forum and found a few with issues but their resolutions don't seem to work for us.

Angela :(

Please Log in to join the conversation.

More
3 years 1 month ago #101969 by DenisChenu
Hi,

I don't view this issue before, maybe you can put this in bug report system with complete phpinfo print screen.

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

More
3 years 1 month ago #102100 by Anje
Thank you for your help, I have installed on another server with Centos 6.4 OS and its working fine except that the resume button is not working any ideas?

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form