Check out the LimeSurvey source code on GitHub!
Welcome, Guest
Username: Password:

TOPIC: Problems getting started with the LimeSurvey XAMPP package

Problems getting started with the LimeSurvey XAMPP package 2 years 10 months ago #101732

  • akrawitz
  • akrawitz's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 1
  • Karma: 0
I've installed the LimeSurvey XAMPP package as described here:
manual.limesurvey.org/Installation_of_th...Survey_XAMPP_package

The installation seems to go fine.

However, when I navigate to http://localhost/admin, I get forwarded to http://localhost/index.php?r=admin and the page has the following error message:
Internal Server Error

CDbConnection failed to open the DB connection.

An internal error occurred while the Web server was processing your request. Please contact the webmaster to report this problem.

Thank you.


According to the XAMPP Control Panel, both Apache and MySql are running. When I look in C:\xampp\apache\logs\error.log I don't see any problems. When I look in C:\xampp\apache\logs\access.log I see a normal looking entry with "GET /index.php?r=admin". When I look in C:\xampp\mysql\data\mysql_error.log I see some errors during startup, such as:
131120 1:42:59 [ERROR] Native table 'performance_schema'.'events_waits_current' has the wrong structure
but these errors are followed by:
131120 1:42:59 [Note] mysql\bin\mysqld.exe: ready for connections.
and then nothing.

Any ideas on what is going wrong?

Thanks,
Adam
The administrator has disabled public write access.
Time to create page: 0.573 seconds
Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form