Unable to Display Tokens After Upgrade

More
3 years 7 months ago - 3 years 7 months ago #100142 by kripp88
kripp88 created the topic: Unable to Display Tokens After Upgrade
I just recently completed an upgrade from 1.90 to 2.0. Everything seems to be working as intended, but I am unable to Display Tokens for some surveys. I can't quite seem to figure out the pattern, but some surveys work and others don't. When the issue happens I am sent to a HTTP 500 page after clicking Display Tokens. Can you tell me what the SQL that is used to run for the 'Display Tokens' page or what file I might find it in? I want to determine if it is a problem with the table/data itself or something like along the lines of a timeout. Any other ideas are greatly appreciated.

Thanks,
Kyle
Last Edit: 3 years 7 months ago by c_schmitz.

Please Log in to join the conversation.

More
3 years 7 months ago #100178 by c_schmitz
c_schmitz replied the topic: Unable to Display Tokens After Upgrade
First step would be to activate debug mode in /application/config/config.php - you should get a more detailed error then.

Best regards

Carsten Schmitz
LimeSurvey project leader
The following user(s) said Thank You: kripp88

Please Log in to join the conversation.

More
3 years 7 months ago #100201 by kripp88
kripp88 replied the topic: Unable to Display Tokens After Upgrade
Thank you, that was very helpful. After turning debugging to 2 and SQL Logging on I saw the following error, "Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 515 bytes) in C:\inetpub\wwwroot\limesurvey\framework\db\CDbCommand.php on line 506". I then increased the php memory allocation from 128M to 1024M which solved the problem for all but one of my surveys. The problem survey has more than 90,000 tokens. Since 1G seems like a lot to allocate to php is it safe to assume that there must be a memory leak somewhere or is allocating this much memory normal?

Thanks,
Kyle

Please Log in to join the conversation.

More
3 years 7 months ago - 3 years 7 months ago #100203 by c_schmitz
c_schmitz replied the topic: Unable to Display Tokens After Upgrade
What is the LimeSurvey version and build you are using?

Best regards

Carsten Schmitz
LimeSurvey project leader
Last Edit: 3 years 7 months ago by c_schmitz.

Please Log in to join the conversation.

More
3 years 7 months ago #100204 by kripp88
kripp88 replied the topic: Unable to Display Tokens After Upgrade
Version 2.00+ Build 130802

Please Log in to join the conversation.

More
3 years 7 months ago #100210 by c_schmitz
c_schmitz replied the topic: Unable to Display Tokens After Upgrade
Can you try and update to the latest build of 2.0+ and see if the issue still exists?
I just created a survey with 10,000 tokens and had no problems at all (memory limit at 80MB).
What PHP version are you using? Maybe your PHP version has a bug leaking memory.

Best regards

Carsten Schmitz
LimeSurvey project leader

Please Log in to join the conversation.

More
3 years 7 months ago #100259 by kripp88
kripp88 replied the topic: Unable to Display Tokens After Upgrade
I just updated to the most recent build (130929) and was unable to view tokens on a table with 50,000 without significantly increasing the php memory limit. I will continue to investigate, but it appears there must be a leak somewhere or a bug in php.

Please Log in to join the conversation.

More
3 years 7 months ago #100260 by c_schmitz
c_schmitz replied the topic: Unable to Display Tokens After Upgrade
Sorry, I meant 100,000 tokens (which I created). What PHP version are you using?

Best regards

Carsten Schmitz
LimeSurvey project leader

Please Log in to join the conversation.

More
3 years 7 months ago #100261 by kripp88
kripp88 replied the topic: Unable to Display Tokens After Upgrade
It is php v 5.4

Please Log in to join the conversation.

More
3 years 7 months ago #100262 by c_schmitz
c_schmitz replied the topic: Unable to Display Tokens After Upgrade
Well, latest PHP version is 5.5.4 - I would try a PHP upgrade (or to countercheck any different version would do) first.

Best regards

Carsten Schmitz
LimeSurvey project leader

Please Log in to join the conversation.

More
3 years 7 months ago #100300 by kripp88
kripp88 replied the topic: Unable to Display Tokens After Upgrade
We are currently running on IIS and using MS-SQL. Since LS requires SQL PDO drivers, I believe that php 5.4 is the latest version that includes these drivers.

-Kyle

Please Log in to join the conversation.

More
3 years 7 months ago - 3 years 7 months ago #100311 by c_schmitz
c_schmitz replied the topic: Unable to Display Tokens After Upgrade
And you are already running 5.4.19? Or an earlier 5.4 version?

Best regards

Carsten Schmitz
LimeSurvey project leader
Last Edit: 3 years 7 months ago by c_schmitz.

Please Log in to join the conversation.

More
3 years 7 months ago #100368 by kripp88
kripp88 replied the topic: Unable to Display Tokens After Upgrade
It is 5.4.14. Do you think there would be a difference with 5.4.19?

-Kyle

Please Log in to join the conversation.

More
3 years 7 months ago #100371 by c_schmitz
c_schmitz replied the topic: Unable to Display Tokens After Upgrade
Chances are good so I would give it a try.

Best regards

Carsten Schmitz
LimeSurvey project leader

Please Log in to join the conversation.

More
3 years 7 months ago #100479 by kripp88
kripp88 replied the topic: Unable to Display Tokens After Upgrade
I just updated to 5.4.20 and the problem still exists, I needed to allocate 2GB to php memory in order to Display Tokens

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now