Check out the LimeSurvey source code on GitHub!

Error in tokens CSV archive

More
3 years 4 months ago #99972 by soyvik
Hello
I have recently made an upgrade to Limesurvey 2.00+ (build 130913) and I am experiencing an error when I try to export the tokens to a CSV archive.
I do the export as I have always made it and I get a file. However, when I open that file, it has the 32 first lines correct (with the correct information of my tokens) but from the 33th line I get the following text:

<!DOCTYPE html PUBLIC
"-//W3C//DTD XHTML 1.0 Transitional//EN""
" www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd "">
<html xmlns=" www.w3.org/1999/xhtml " xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html
<title>Internal Server Error</title>
<style type="text/css">
/*<![CDATA[*/
body {font-family:"Verdana"
h1 { font-family:"Verdana"
h2 { font-family:"Verdana"
h3 {font-family:"Verdana"
p {font-family:"Verdana"
.version {color: gray
/*]]>*/
</style>
</head>
<body>
<h1>Internal Server Error</h1>
<h2>SQLSTATE[HY000]: General error: 2014 Cannot execute queries while other unbuffered queries are active. Consider using PDOStatement::fetchAll(). Alternatively, if your code is only ever going to run against mysql, you may enable query buffering by setting the PDO::MYSQL_ATTR_USE_BUFFERED_QUERY attribute.</h2>
<p>
An internal error occurred while the Web server was processing your request.
Please contact the webmaster to report this problem.
</p>
<p>
Thank you.
</p>
<div class="version">
2013-09-20 09:47:06 </div>
</body>
</html>


Does anyone know what is happening? How can I fix it?
Thank you

Please Log in to join the conversation.

More
3 years 4 months ago #99976 by DenisChenu
Hi,

Did you use the last version AND the last build? Carsten put a lot of fix for this.

If yes : please fill a bug report

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

More
3 years 4 months ago #99984 by soyvik
Yes, as I said, I have installed the last build (build 130913).
We have fixed the problem by adding the following text:

$pdo->setAttribute(PDO::MYSQL_ATTR_USE_BUFFERED_QUERY, true);

in the line 436 of the file: limesurvey/framework/core/CDbconnection.php

The problem seems to be related to the release of MySql, so this solution could not be useful for everyone.

Please Log in to join the conversation.

More
3 years 4 months ago #100000 by DenisChenu

soyvik wrote: Yes, as I said, I have installed the last build (build 130913).
We have fixed the problem by adding the following text:

$pdo->setAttribute(PDO::MYSQL_ATTR_USE_BUFFERED_QUERY, true);

in the line 436 of the file: limesurvey/framework/core/CDbconnection.php

The problem seems to be related to the release of MySql, so this solution could not be useful for everyone.

Please: can you post a bug report ?
It can be fixed in next release for all user.

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

More
3 years 3 months ago #100032 by soyvik
Where should I post the bug?

Please Log in to join the conversation.

More
3 years 3 months ago #100072 by DenisChenu

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

More
3 years 3 months ago #100154 by soyvik
Done!
The following user(s) said Thank You: DenisChenu

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form