Equation results are errased when editing survey

More
4 years 4 months ago #98273 by ARamirez
ARamirez created the topic: Equation results are errased when editing survey
Hi, we are experiencing the next problem with LS Versión 2.00+ Build 130708:

We have a survey with equations that are sum of the questions, if we return with same token to edit a survey entry, the equation value is saved as zero, no matter what options are selected.

Steps to reproduce:

I. Make a survey with three questions:
Q1) Do you like candys? A)5 B)0
Q2) Do you like sodas? A)5 B)0
Q3) SUM Q1.value+Q2.value

II. Fill a survey answering "A" option for the two questions, the result of Q3 will be recorded as 10

III. Open again the survey entry from the client side with same token, the answers are still there (A,A), and wether you change them, select them again or do nothing, after saving the survey the result of Q3 is set to zero.

Do anyone has had this issue or can help with an idea of how to solve it?

Thanks in advance.

Please Log in to join the conversation.

More
4 years 3 months ago #98340 by DenisChenu
DenisChenu replied the topic: Equation results are errased when editing survey

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!