Check out the LimeSurvey source code on GitHub!

Answers not recorded when returning to a survey that has been started

More
3 years 8 months ago #96801 by alexmessinger
I have found that answers are not recorded when performing the following steps.

User receives link to survey
User clicks on link, survey opens in browser
[response is recorded in Lime survey as not completed]
User opens another browser tab, closes tab with survey
User clicks on link in email again, survey opens in browser
User completes survey
[response is now recorded as complete, but no answers are recorded]

Illustration: screencast.com/t/iWmsxJ4oa

Is this a known bug or am I doing something incorrectly?

Please Log in to join the conversation.

More
3 years 8 months ago #96814 by DenisChenu

alexmessinger wrote: Is this a known bug or am I doing something incorrectly?

Gloups, seem it's a bug (I think).

Did you try with last version ?

Did it happen with grop by group survey (or q by q) ?

Think put a bug report is a good solution.

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

More
3 years 7 months ago #97883 by alexmessinger
It seems like whenever the page is refreshed, answers subsequently entered are not recorded.

Please Log in to join the conversation.

More
3 years 7 months ago #97888 by DenisChenu
Please: give us your version and the build number.

The PHP version and the database type and version can be interseting too.

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

More
3 years 5 months ago #99685 by alexmessinger
Hi Denis: Lime survey 1.92+. We're using MySQL server version 5.5.33

Please Log in to join the conversation.

More
3 years 5 months ago #99693 by alexmessinger
I did some more testing, and the answers are erased only when there is more than one question group. I tested with 1 or 2 questions contained in the same group, and answers were recorded.

Please Log in to join the conversation.

More
3 years 5 months ago #99694 by alexmessinger
How do I find the Lime Survey Build number in order to submit a bug?

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form