LDAP Issue (and a query about question conditions)

More
4 years 3 days ago #95222 by TarkiB
TarkiB created the topic: LDAP Issue (and a query about question conditions)
Hi there,

I have two somewhat unrelated questions. I'm running version 2.00+ Build 130406, on Windows with Apache/MySQL.

1) Question conditions: Each question can have a condition applied to it to determine when it is visible. Can conditions be applied to a question group, instead of having to apply conditions for each individual question? This way, a question group could be visible/invisible, depending on a previous answer.

2) I'm setting up LDAP with AD to import tokens. I can successfully bind to the LDAP server, but it gives me the following results:

1 Results from LDAP Query.
0 records met minimum requirements
0 Records imported.
0 Duplicate records removed
0 records with invalid email address removed


I'm running the following query, which should only return 1 user. I know for a fact that this user is in AD:
$query_id=0;
$LDAP_queries[$query_id]['ldapServerId'] = 0;
$LDAP_queries[$query_id]['name'] = 'Staff with with Bh in name';
$LDAP_queries[$query_id]['userbase'] = 'cn=users,dc=development,dc=local';
$LDAP_queries[$query_id]['userfilter'] = '(&(objectCategory=person)(objectClass=user)(name=Bh*))';
$LDAP_queries[$query_id]['userscope'] = 'sub';
$LDAP_queries[$query_id]['firstname_attr'] = 'name';

It finds one user, which is right, but it apparently it doesn't meet 'minimum requirements'. I'm not sure why that is. All it should be doing is finding names that begin with 'Bh'.

Any help would be appreciated.

Cheers.

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now