Check out the LimeSurvey source code on GitHub!

How do I update / upgrade the jquery version?

More
3 years 10 months ago #94870 by McdanielMackenzie
Hi. I am using a 2.0+ version of LS but have been running into some issues with scripting. After digging deeper, I've learned that the version of jquery LS is using on my system is version 1.5.2. This is several years out of date and is missing some needed functionality.

How do I update / upgrade? And if it's real basic, I'm hoping someone will tell me "No, you won't break anything".

Beyond that, is there not a way to auto-upgrade this library? It seems like every time I log into my LS admin panel there is a new version / upgrade of the base package available. Would love to see this upgrade feature include any additional libraries or packages that LS utilizes.

Thanks for any help.

-MM

Please Log in to join the conversation.

More
3 years 10 months ago #94877 by McdanielMackenzie
Hmm... after some experimenting, you can change the jquery.js file to a more recent version. However, when I changed mine to the most recent, it broke. So I put the old version back and it worked. I tried a more benign step-approach and dropping in 1.6.3 seems to work.

I'm going to stop there and hope a developer in the know chimes in. I'd rather not try a tinker/test, tinker/test approach since that typically only works until it doesn't.

Honestly, I'd prefer to link to a CDN for "always updated" functionality.

Thoughts?

Please Log in to join the conversation.

More
3 years 10 months ago #94882 by holch
I am not a developer, but I assume the developers "froze" jquery in order not to have to worry about every jquery update breaking Limesurvey. But that is just my guess.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
3 years 10 months ago #94892 by Mazi

holch wrote: I am not a developer, but I assume the developers "froze" jquery in order not to have to worry about every jquery update breaking Limesurvey. But that is just my guess.

You are most probably right about that, see bugs.limesurvey.org/view.php?id=6505

-> The upcoming Limesurvey 2.05 will use the latest jquery version.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
3 years 10 months ago #94919 by DenisChenu

McdanielMackenzie wrote: I tried a more benign step-approach and dropping in 1.6.3 seems to work.

I think jq1.8/ui1.9 work without big problem.

We can include jquery-CDN: because sometimes an jquery update break some compatibility (like .browser actually).

Denis
(and yes : 2.05 have last jquery version, and use a specific diectory.)

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form