No input file specified. Blank Page. Error on Ver. 2 Installation

3 years 11 months ago #94209 by tiziano
i try to give more info as i can to describe my problem.
I have used version 1.9x since now without problems.
I recently tried to upgrade to version 2.xx, first with an update from the previous version, and than, more times, with new clean installations.
I carefully read both the docs and forums for installation how-to and issues solved but i can't find something for my situation.
Every time i try to get the installation ver. 2 to work i find the same problems, here the explanation:

linux hosting by Aruba (italian) maintainer with MySQL 5.0.92 and PHP 5.3.22
I download the installation package, unpack, upload FTP to my location, check database that is clean and empty, check the access to directories as written in how-to-install, join the URL for the installation,
- (step 1-3) all the required requirements are OK, (i am only missing 2 optional PHP Extensions LDAP and zip lib),
- (step 4) fill in the form MySQL info (name-password-host...), and
- (step 5) populate the database (it works fine as i can see from phpmyadmin)
- (step 6) fill form for optional informations (last step)
Ok, from that step it does not work anymore. From the page, after form in step 6, at i find, first, the error "No input file specified."
If i look in / i find config.php with all it needs, filled with the info i have submitted during the installation process(including step 6).
If i surf to i see the right page as expected, where is written that there are "No available surveys". But if, for example, i try to change language ( or i try to join to admin page ( i always get the same result: a blank page with only this written "No input file specified."
I have one installation, done for testing, at this URL
The DOCUMENT_ROOT is /web/htdocs/
All makes me think that it does not find the files... is there something i can add/change in config files to help this?
I have tried to set 'debug'=>1, in config file to see if there are errors but nothing changed.
I have tried to get new installations, in other domains, more times but nothing changed.

Please Log in to join the conversation.

3 years 11 months ago #94224 by DenisChenu

Think it's a "bad" url manager issue: your server seems compatible with some setting, but it's not .

Try this in config.php:
'urlManager' => array(
			'urlFormat' => 'path',
			'rules' => require('routes.php'),
			'showScriptName' => true,

'urlManager' => array(
			'urlFormat' => 'get',
			'rules' => require('routes.php'),
			'showScriptName' => true,


Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
The following user(s) said Thank You: tiziano

Please Log in to join the conversation.

3 years 11 months ago #94228 by tiziano
Thank you very much!!!
It works fine, problem solved! :)

Please Log in to join the conversation.

3 years 11 months ago #94577 by tiziano
Just to complete the solution of my problem i have to add more steps i have done.
- after changing urlFormat value to "get" i can see admin page and so on but i can't login becouse the super-user created during the installation was not created.(no way to create it, dunno why)
- so i add a superuser directly in MySQL without any password but with the right email in lime_users
- than i try to join with that user and using the lost-password i get an email with a password.
- finally i can join and i'am able to use all.
Not very elegant but effective solution.
The following user(s) said Thank You: DenisChenu

Please Log in to join the conversation.