Update from 1.91 to 2 won't connect to SQL database

More
4 years 5 months ago #92284 by ccrobins
ccrobins created the topic: Update from 1.91 to 2 won't connect to SQL database
We have been successfully running 1.91 on Server 2008R2, PHP 5.3.8 and the database resides on a SQL 2008R2 cluster. After following the update procedures the installer via the admin page keeps failing to connect to the database. Should I see more than MYSQL in the database type drop down? It was working. Thanks..

Please Log in to join the conversation.

More
4 years 5 months ago #92494 by ccrobins
ccrobins replied the topic: Update from 1.91 to 2 won't connect to SQL database
Sorry I did not mention that we are running it in IIS 7. I now have "Microsoft SQL Server (sqlsrv)" showing up in the database type field in the installer using the php_pdo_sqlsrv_53_nts.dll driver, however after entering the rest of the info on the installer page and clicking next I immediately get: Connection with database failed. Please check database location, user name and password and try again. I know the information is correct. Any ideas? Thanks..

Please Log in to join the conversation.

More
4 years 5 months ago #92498 by holch
holch replied the topic: Update from 1.91 to 2 won't connect to SQL database
As LS 2.0 uses a different database driver, this could be the problem.

Requirements say that you need the pdo driver for mysql. I am not sure if it works with microsoft SQL at all...

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
4 years 5 months ago #92508 by ccrobins
ccrobins replied the topic: Update from 1.91 to 2 won't connect to SQL database
Thanks for the reply! Unfortunately I get the same response using php_pdo_mysql.dll driver.

Please Log in to join the conversation.

More
4 years 5 months ago #92514 by holch
holch replied the topic: Update from 1.91 to 2 won't connect to SQL database
ISS has always been an issue. I don't think that anyone of the limesurvey team has a ISS to test LS with it.

LS best works in the LAMP version.

Maybe someone of the developers comes by and has a solution.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

Did you already participate in our customer survey?

Don't miss your chance for great prices.

Please click here to participate:

Start now

Start now!

Just create your account and start using Limesurvey today.

Register now