Problem after Update from 1.8 to 2.0

More
4 years 9 months ago #91918 by MalteHommes
MalteHommes created the topic: Problem after Update from 1.8 to 2.0
Hi,

i just now update my limeSurvey installation. Now i get the following message when trying to test a survey

xxxx.xx/index.php/57538/lang-de

The table "{{survey_url_parameters}}" for active record class "Survey_url_parameters" cannot be found in the database.

can you maybe give me a hint what could be wrong? The backend works fine.

Thanks a lot in advance,

Malte

Please Log in to join the conversation.

More
4 years 9 months ago #91920 by mdekker
mdekker replied the topic: Problem after Update from 1.8 to 2.0
Your database is missing a table

---
Menno Dekker
The following user(s) said Thank You: MalteHommes

Please Log in to join the conversation.

More
4 years 9 months ago #91921 by MalteHommes
MalteHommes replied the topic: Problem after Update from 1.8 to 2.0
hello,

thank you very much for you help. now i would like to call "admin/install" to update the database but i am getting the message "The system is unable to find the requested action "install"."

can u maybe help me again ? :D thanks

Please Log in to join the conversation.

More
4 years 9 months ago #91922 by mdekker
mdekker replied the topic: Problem after Update from 1.8 to 2.0
Can you login to the admin part? Database upgrade should be automatic. If it failed, you can have a lot of problems that can not be fixed easily. Best would be to revert to your old install and update in smaller version steps or export surveys and import in a new install.

---
Menno Dekker
The following user(s) said Thank You: MalteHommes

Please Log in to join the conversation.

More
4 years 9 months ago #91923 by MalteHommes
MalteHommes replied the topic: Problem after Update from 1.8 to 2.0
hello,

i can login just fine. i hoped to not have to explain the whole situation but i guess i now have to. maybe there is an easier way now to solve my problem (i will be as brief as possible)

there are two servers. Live and Stage. There are 2 limesurvey installations on Stage. one of them points towards the Staging database. The other to the Live database. So there are two installations and the only difference is the database host in the config-file.

This is done because there must not be an admin-section on the live server. I updated both folders and the staging folder works just fine.

Now to my question: is there a better way to use two different installations for this or is there an easier way to "switch config-files"?

I will now try to revert to the old version and to update againg.

thanks for your help!

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!