Adding a language - Property "CDbCriteria.0" is not defined.

More
4 years 4 months ago #91758 by GalloiseBlonde
GalloiseBlonde created the topic: Adding a language - Property "CDbCriteria.0" is not defined.
Hi hello!

I was keen to use the new build because there is a new language on there that I desperately need. However, when I try to add any language to my base English survey I get the error message
Property "CDbCriteria.0" is not defined.
. What's that about, and what can I do?

Please Log in to join the conversation.

More
4 years 4 months ago #91762 by mdekker
mdekker replied the topic: Adding a language - Property "CDbCriteria.0" is not defined.
The bug will be fixed in the next version. If you are in a hurry and want to edit the file yourself, check out this commit:
github.com/LimeSurvey/LimeSurvey/commit/...5c4c377351c61b844272

---
Menno Dekker
The following user(s) said Thank You: GalloiseBlonde

Please Log in to join the conversation.

More
4 years 4 months ago #91776 by GalloiseBlonde
GalloiseBlonde replied the topic: Adding a language - Property "CDbCriteria.0" is not defined.
Thank you mdekker, I may well give that a go. Love the UI on the latest build BTW.

Please Log in to join the conversation.

More
4 years 3 months ago - 4 years 3 months ago #91832 by GalloiseBlonde
GalloiseBlonde replied the topic: Adding a language - Property "CDbCriteria.0" is not defined.
Hi - it turns out there is another problem with secondary languages in the new build, which is that template changes and so on are only affecting the primary language. Annoyingly, this means my secondary language is appearing as question by question rather than in pages, and not using the template I redesigned with logos and stuff. Does anyone have any idea what's going on there?

PS: mdekker's alt worked perfectly!
Last Edit: 4 years 3 months ago by GalloiseBlonde.

Please Log in to join the conversation.

More
4 years 3 months ago #91833 by mdekker
mdekker replied the topic: Adding a language - Property "CDbCriteria.0" is not defined.
Probably your second language has no settings. Try changing texts for the language, that should fix your problem. If not, I think it will be fixed in the next build since some changes related to this have been done. The next build will probably be released later today (when we find no big issues)

---
Menno Dekker
The following user(s) said Thank You: GalloiseBlonde

Please Log in to join the conversation.

More
4 years 3 months ago #91835 by GalloiseBlonde
GalloiseBlonde replied the topic: Adding a language - Property "CDbCriteria.0" is not defined.
I reckon I'll wait for the new build then, if it's coming so soon. Thank you so much: your responses here have been very impressive. I'm glad I chose Limesurvey.

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now