Problem to insert javascript in a question

More
4 years 6 months ago #91672 by lfanfoni
lfanfoni created the topic: Problem to insert javascript in a question
Hi,
I have many problems with my versions 1.92, build 120418 & 120530, in particular I cannot insert any javascript script in a question.
In detail (see attached images):
1) in the "source" edit box of a "Text display" question, I write a sample javascript
2) when I save the question, the script is visible in the text question
3) when I open in editing the question, the tag of the script is corrupted.

I have also problems with the EM, expecially to link to question code. But, if I solve with javascript, I can finish my survey even so.
Attachments:

Please Log in to join the conversation.

More
4 years 6 months ago #91680 by Ben_V
Ben_V replied the topic: Problem to insert javascript in a question
and the XSS filter? ;)
See doc
Ben/

Benoît

EM Variables => bit.ly/1TKQyNu | EM Roadmap => bit.ly/1UTrOB4
Last Releases => 2.6x.x goo.gl/ztWfIV | 2.06/2.6.x => bit.ly/1Qv44A1
Demo Surveys => goo.gl/HuR6Xe (already included in /docs/demosurveys)
The following user(s) said Thank You: lfanfoni

Please Log in to join the conversation.

More
4 years 6 months ago #91682 by lfanfoni
lfanfoni replied the topic: Problem to insert javascript in a question
Yes, I had completely forgotten about that damn option ... eternal gratitude .... I came back to life!

Please Log in to join the conversation.

Did you already participate in our customer survey?

Don't miss your chance for great prices.

Please click here to participate:

Start now

Start now!

Just create your account and start using Limesurvey today.

Register now