Check out the LimeSurvey source code on GitHub!
Welcome, Guest
Username: Password:

TOPIC: Problem to insert javascript in a question

Problem to insert javascript in a question 3 years 6 months ago #91672

  • lfanfoni
  • lfanfoni's Avatar
  • Offline
  • Platinum Lime
  • Posts: 536
  • Thank you received: 98
  • Karma: 24
Hi,
I have many problems with my versions 1.92, build 120418 & 120530, in particular I cannot insert any javascript script in a question.
In detail (see attached images):
1) in the "source" edit box of a "Text display" question, I write a sample javascript
2) when I save the question, the script is visible in the text question
3) when I open in editing the question, the tag of the script is corrupted.

I have also problems with the EM, expecially to link to question code. But, if I solve with javascript, I can finish my survey even so.
Attachments:
The administrator has disabled public write access.

Problem to insert javascript in a question 3 years 6 months ago #91680

  • Ben_V
  • Ben_V's Avatar
  • Offline
  • Platinum Lime
  • Posts: 1790
  • Thank you received: 439
  • Karma: 110
and the XSS filter? ;)
See doc
Ben/
Benoît

EM Variables => bit.ly/1TKQyNu | EM Roadmap => bit.ly/1UTrOB4
All LS releases => bit.ly/1VMuTDu | 2.06lts => bit.ly/1Qv44A1
Demo surveys => bit.ly/20NW9V8 (already included in /docs/demosurveys)
The administrator has disabled public write access.
The following user(s) said Thank You: lfanfoni

Problem to insert javascript in a question 3 years 6 months ago #91682

  • lfanfoni
  • lfanfoni's Avatar
  • Offline
  • Platinum Lime
  • Posts: 536
  • Thank you received: 98
  • Karma: 24
Yes, I had completely forgotten about that damn option ... eternal gratitude .... I came back to life!
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.234 seconds
Imprint                   Data Protection Statement                  Revocation information and revocation form