Check out the LimeSurvey source code on GitHub!
Welcome, Guest
Username: Password:

TOPIC: Couldn't get question SELECT * FROM {{questions}}

Couldn't get question SELECT * FROM {{questions}} 3 years 10 months ago #90978

  • Enki
  • Enki's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 3
  • Karma: 0
I keep getting the error:

Couldn't get question
SELECT * FROM {{questions}} WHERE qid=6 AND language='en'

When trying to complete the survey.

It's a fresh install on a server running PHP 5.1.2 w/json.

It has 1 survey with two questions that have subquestions with arrays. For example:

Why did you choose X?
It has great services [Agree] [Agree Somewhat] [Disagree Somewhat] [Disagree]
You seem trustworthy [Agree] [Agree Somewhat] [Disagree Somewhat] [Disagree]

Please help. Attached is a screenshot of the survey logic result.
Attachments:
Last Edit: 3 years 10 months ago by Enki.
The administrator has disabled public write access.

Aw: Couldn't get question SELECT * FROM {{questions}} 3 years 10 months ago #91057

  • mbarz
  • mbarz's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 2
  • Karma: 1
Hello,

I got the same error:
Couldn't get question
SELECT * FROM {{questions}} WHERE qid=2 AND language='de'

I have nearly the same setup: 1 survey with 2 questions.
My serverconfig is the following:
php 5.1.6 with json 1.2.1 and mysql 5.0.95.
I'm running the newest build V2 130110.

I'm really confused about this problem.
Inserting the first question was no problem. After the second question the question preview was possible one time. After that no preview was possible anymore.

Deleting the affected question fixes the issue, but not my problem because after inserting another question the problem occurs again.
Nevertheless, creating a printable version of the questionnaire is no problem.

Hope someone can help...

Kind regards,

Michael Barz
Last Edit: 3 years 10 months ago by mbarz.
The administrator has disabled public write access.

Aw: Couldn't get question SELECT * FROM {{questions}} 3 years 10 months ago #91063

  • c_schmitz
  • c_schmitz's Avatar
  • Online
  • LimeSurvey Team
  • Posts: 1033
  • Thank you received: 135
  • Karma: 97
Try this patch and report if that solved your problem:
github.com/LimeSurvey/LimeSurvey/commit/...91f716e071babd7312d3
Best regards

Carsten Schmitz
LimeSurvey project leader
The administrator has disabled public write access.
The following user(s) said Thank You: mbarz

Couldn't get question SELECT * FROM {{questions}} 3 years 10 months ago #91064

  • mbarz
  • mbarz's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 2
  • Karma: 1
Hello,

thanks for this hint.
The preview works now!

Kind regards,

Michael Barz
Last Edit: 3 years 10 months ago by mbarz.
The administrator has disabled public write access.

Couldn't get question SELECT * FROM {{questions}} 3 years 10 months ago #91149

  • Enki
  • Enki's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 3
  • Karma: 0
We're getting close! I'm now getting the error:

Internal Server Error
The table "{{answers}}" for active record class "Answers" cannot be found in the database

Survey logic screenshot: i.imgur.com/t8ike.png
Last Edit: 3 years 10 months ago by Enki.
The administrator has disabled public write access.
Time to create page: 0.526 seconds
Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form