No Surveys after upgrading from 1.92 to 2.00

More
4 years 11 months ago #90184 by brisyb
brisyb created the topic: No Surveys after upgrading from 1.92 to 2.00
I have just upgraded from version 1.92 to 2.00.

I followed all the instructions including backing up the databse before the upgrade. I had no errors during the upgrade.

However, when I logged there are no surveys. had three surveys before the upgrade.

Can i restore these from the backup I did, and if so how?

Please Log in to join the conversation.

More
4 years 10 months ago - 4 years 10 months ago #90457 by captainwalker
captainwalker replied the topic: No Surveys after upgrading from 1.92 to 2.00
I'm experiencing the same problem. I'm not sure where surveys are stored. Hopefully in the SQL database (in part).

I've just rolled back my installation to 1.92, exported surveys to both Limesurvey and Xml formats - will then roll forward and import them each.

Thankfully I only have a handful of surveys. I'm sure there must be a more efficient way to do this. Someone please help.

Addendum:
Minutes later - having upgraded a second time to 2.00 - I still cannot see all the previous surveys. However, links to previous surveys in 1.92 format are still live. So it seems that the old surveys are still active somewhere in the database or whatever.

Importing the old survey's into new format doesn't change anything. I'm totally confused. :blink:
Last Edit: 4 years 10 months ago by captainwalker. Reason: added and addendum

Please Log in to join the conversation.

More
4 years 10 months ago #90466 by mdekker
mdekker replied the topic: No Surveys after upgrading from 1.92 to 2.00
On what version are you? Make sure you are using the latest version. If you are on the latest version, please file a bug report with as many details as possible.

---
Menno Dekker

Please Log in to join the conversation.

More
4 years 10 months ago #90497 by brisyb
brisyb replied the topic: No Surveys after upgrading from 1.92 to 2.00
mdekker, as we have stated in our posts, we were on version 1.92 and upgraded to 2.00 (the latest version).

captain_walker, how did you roll-back? I can't find any instructions on how to do this properly. Can you help?

Please Log in to join the conversation.

More
4 years 10 months ago #90502 by fransmarcelissen
fransmarcelissen replied the topic: No Surveys after upgrading from 1.92 to 2.00
I upgraded in another way, and it worked fine(as far as I know). I backuped the old database, created a new installation (with a new database name), restored the old database (under the new name, destroying the new database). Then the database is upgraded, with the old data. Now I have two installations, both with surveys and data. I have the impression that 2.00 still contains errors, and for "production work" I keep on using 1.92 for a few months, but now I can test 2.00 with real data.
I hope this information is useful for you.

Please Log in to join the conversation.

More
4 years 10 months ago #90536 by Mazi
Mazi replied the topic: No Surveys after upgrading from 1.92 to 2.00
All the survey information is stored at the database which you can re-import from the /tmp folder where the backup is usually created when updating automatically.

If you are not seeing the 1.92 survey, check if you have entered the correct DB name and table prefix when installing Limesurvey 2.
E. g. if any of this doesn't match, new tables are created and thus Limesurvey doesn't read from the existing data.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!