Godaddy Installation problem

More
4 years 5 months ago - 4 years 5 months ago #89724 by jbsarma
jbsarma created the topic: Godaddy Installation problem
I have limesurevy version 2 installed at http://www.learnandshare.net/limesurvey on Godaddy's Linux shared server but when I go to admin page http://www.learnandshare.net/limesurvey/index.php/admin I get an error 'No input file specified.'

I got the following reply from the GoDaddy's support 'When visiting your site and reviewing the files and directories of your application, there appears to be a redirect issue. As such, when visiting www.learnandshare.net/limesurvey/index.php/admin , the files and directories are not being referenced properly. As such, you may need to ensure that the admin directory is being properly referenced on your site. When visiting your site, it is visible and navigational. As such, there are no issues with the hosting plan or the server it resides on.'
It was not helpful as I expected some solution as to the configuration of .htaccess file. Does anybody has any experience of installing Limesurvey 2 (latest build as on 5th Dec 12) on GoDaddy's Linux server. Thanks in advance.
Last Edit: 4 years 5 months ago by jbsarma.

Please Log in to join the conversation.

More
4 years 5 months ago - 4 years 5 months ago #89740 by DenisChenu
DenisChenu replied the topic: Godaddy Installation problem

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .
Last Edit: 4 years 5 months ago by DenisChenu.

Please Log in to join the conversation.

More
4 years 4 months ago #90588 by kit
kit replied the topic: Godaddy Installation problem
I couldn't get this to work either on Godaddy. Everything uploaded ok to the site using FileZilla (tried it twice) and the install would go smoothly until creating the admin account. Then the install bombed with the "No input file specified." error and there was no user in the lime_users db table.

I also would get the error when I attempted to navigate to /limesurvey/index.php/admin/.

I searched the forums and found a thread saying that FastCGI was to blame . After much frustration, I finally caved and changed the option: Hosting -> File Extensions Management -> .php extension changed from "PHP 5.3.x FastCGI" to "PHP 5.2.x". I deleted limesurvey/application/config, dropped all the tables in my DB, and went to /limesurvey/index.php/installer/welcome. This time, the installer worked and I was able to login.

I can currently reproduce the issue on the site by changing the file extension option and attempting to navigate to /limesurvey/index.php/admin. Is there anymore information I can provide in order to troubleshoot?

Please Log in to join the conversation.

More
4 years 4 months ago #90656 by haniar
haniar replied the topic: Godaddy Installation problem
I am having the same problem on godaddy. I tried your suggestion of 5.2 but only Fast CGI option is available with it. It did not work. Anything else I should watch for.

I have loaded the zipped file and unzipped in file manager. I suspect something has gone wrong with permissions in the unzipping process

Please Log in to join the conversation.

More
4 years 2 months ago #93205 by kit
kit replied the topic: Godaddy Installation problem
Ok I think I finally figured it out. You can use PHP 5.3 with a small tweak.

First, validate you have PHP 5.3 set in your Godaddy web hosting control panel,
  • Under More -> Programming Languages validate it is set to PHP 5.3.
  • Under More -> Programming Languages validate the .php extension is set to PHP 5.3.x FastCGI.
The root of the issue is that there is a php configuration setting, cgi.fix_pathinfo, which should be 1 by default . On Godaddy's servers this is set to 0!

Create a new file in the ROOT of your Godaddy server named php5.ini and put inside of it:
cgi.fix_pathinfo=1

Works for me!

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now