Transferred installation to a new server, having trouble

4 years 3 months ago #89589 by DaMoisture
I did a quick search and could not find any immediate help, this is time sensitive so I apologize in advance if my search wasn't thorough enough.

I am receiving the following error whenever I try to access the survey:

Can't connect to LimeSurvey database. Reason: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)

I have the exact same MySQL database name and user name on our new server (unless there is something I missed, have been over it twice though). There are a lot of placeholder URLS in my config.php, might one of them be holding it up?

/// Basic Setup
$databasetype = 'mysql'; // ADOdb database driver - valid values are mysql, mysqli, odbc_mssql, mssql_n, odbtp or postgres
// mysql:
Recommended driver for mysql
// mysqli: Slightly faster driver for mysql - not on all server systems available
// odbc_mssql: MSSQL driver using ODBC with MS SQL Server
// mssql_n: Experimental driver for MS SQL Server which handles UTF-8 charsets
// odbtp: ODBTP driver to access MSSQL-Server is needed for this one - we also recommend to activate $databasepersistent for decent speed
// postgres: Standard postgres driver
$databaselocation = 'localhost'; // Network location of your Database - for
odbc_mssql use the mssql servername, not localhost or IP

$databasename = 'ncsac4pd_lime'; // The name of the database that we will create
$databaseuser = 'ncsac4pd_lime'; // The name of a user with rights to create db (or if db already exists, then rights within that db)
$databasepass = 'correctly entered in actual file'; //
Password of db user
$dbprefix = 'lime_'; // A global prefix that can be added to all LimeSurvey tables. Use this if you are sharing
// a database with other applications. Suggested prefix is 'lime_'
// File Locations
$rooturl = "http://{$_SERVER}"; // The root web url for
your limesurvey installation (without a trailing slash).
// The double quotes (") are important.


= dirname(__FILE__); // This is the physical disk location for your limesurvey installation. Normally you don't have to touch this

// setting. If you use IIS then you MUST enter the complete rootdir e.g. : $rootDir='C:\Inetpub\wwwroot\limesurvey'!
// Some IIS

and OS/2 installations also require to use forward slashes
// instead of backslashes, e.g. $rootDir='C:/Inetpub/wwwroot/limesurvey'!

//installation Setup
$defaultuser = 'stmoist'; // This is the username when LimeSurvey is installed and the administration user is created on installation
$defaultpass = 'c4pd;131'; // This is the password for the administration user when LimeSurvey is installed

// Debug Settings
$debug = 0;

// Set this to 1 if you are looking for errors. If you still get no errors after enabling this
// then please check your error-

logs - either in your hosting provider admin panel or in some /logs dir
// on your webspace.

// LimeSurvey developers: Set this to 2 to circumvent the restriction to remove the installation directory
// or to change the

password. If you set it to 3 then PHP STRICT warnings will be shown additionally.

Thanks in advance for any help!

Please Log in to join the conversation.

4 years 3 months ago #89593 by jelo
Is any other program using the mysql database server on this new server?
To me this looks like mysql is not running at all.

Sometimes the socketfile is missing because it was in /tmp and someone deleted the whole directory. Sometimes it is a blocked connection via localhost.

Out of scope for a limesurvey forum.

Take a look at this thread to get some ideas what to check

Please Log in to join the conversation.

4 years 3 months ago #89713 by DaMoisture
Thank you for the prompt response! This is actually just turning out to be another problem in an endless string. I can't recommend IPower hosting (moving from HostGator) if you've got anything more complex than a site with a couple email accounts, maybe a database or two.

Please Log in to join the conversation.

4 years 3 months ago #89726 by DaMoisture
Slowly making head way getting the survey up, turned out their mysql path was not localhost, had to change that.

Now the issue is whenever I try to complete the survey at , I immedietly get told my session has expired. Same thing happens whenever I try to use the admin console: I can log in, but as soon as I click any of the links, I get told I have to log in again.

I did some checking around the forum, tried a few things, nothing seemed to work. Here's a link my my

Please Log in to join the conversation.

4 years 3 months ago #89764 by DaMoisture
In case anyone stumbles across this thread with a similar issue, what seemed to fix the issue was changing the session save path in the php settings on the server. I finally got to tier II support at iPower, they were actually quite helpful.

Please Log in to join the conversation.

4 years 3 months ago - 4 years 3 months ago #89785 by jelo
Is this directory existing in your webspace?

If yes, what are the unix permissions?

UPDATE: You fixed it already. Didn't received the last update via Email. Sorry for posting again.

I would remove the phpinfo script from your site and the link in your post. These infos can be used to attack your website much easier.
Last Edit: 4 years 3 months ago by jelo.

Please Log in to join the conversation.

4 years 3 months ago #90066 by DaMoisture

Please Log in to join the conversation.