Check out the LimeSurvey source code on GitHub!

Forbidden /admin directory on local install

4 years 2 months ago #89437 by cberghoff

I'm trying to install on my local machine. Apache 2, php, mysql all are working properly. I 'uploaded' the expanded files using ftp binary mode to a subdirectory of my local web server, yet get "Forbidden You don't have permission to access path/admin on this server" in both Safari and Firefox. I set permissions to 777 on the admin directory and received the same error, so then I set the index.php file to also have 777. I get the same error when trying to access it directly.

I'm guessing this is something to do with my server configuration, and I'm by no means an admin expert! I've set up my Mountain Lion computer according to the directions at:

I've also checked for mod_security as it seems similar messages often are related to this on the forums here, but I find no reference to it on my computer.

Any help would be much appreciated!

Please Log in to join the conversation.

4 years 2 months ago - 4 years 2 months ago #89439 by helper
Check your apache httpd.conf file - apache is stopping you at the door.

Look for something like the following (the important ones are - Order allow,deny and Allow from all towards the end of this node).

Oh, if you make any changes you need to restart apache.
DocumentRoot "c:/etc/Apache/htdocs"
<Directory "c:/etc/Apache/htdocs">
    # Possible values for the Options directive are "None", "All",
    # or any combination of:
    #   Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
    # Note that "MultiViews" must be named *explicitly* --- "Options All"
    # doesn't give it to you.
    # The Options directive is both complicated and important.  Please see
    # for more information.
    Options Indexes FollowSymLinks Includes ExecCGI
    # AllowOverride controls what directives may be placed in .htaccess files.
    # It can be "All", "None", or any combination of the keywords:
    #   Options FileInfo AuthConfig Limit
    AllowOverride All
    # Controls who can get stuff from this server.
    Order allow,deny
    Allow from all
Last Edit: 4 years 2 months ago by helper.

Please Log in to join the conversation.

4 years 1 month ago #91003 by cberghoff
A quick update...

This fix worked, eventually. However, I was not able to get limesurvey to run when using the /username/Sites configuration in Mountain Lion (yes, I edited the proper httpd.conf). Once I started hosting everything from the system level web root and fixed my httpd.conf there, all was OK. Hope this helps someone else out, and thanks for your help helper!

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form