Settings page unable to submit/page redirects when fields include html elements

More
4 years 11 months ago #89236 by ewohwerd
ewohwerd created the topic: Settings page unable to submit/page redirects when fields include html elements
Forgive any existing articles that might be an oversight here.

I recently installed limesurvey via a cpanel tool on a site that is also running wordpress. I can get more technical details but that's about all I can comprehend on my own at this point.

If I leave the inline html editor enabled, any time I try to submit a page (for instance, the main survey text fields settings for description, welcome message, etc.), clicking submit results in a redirect to my site's top directory, and the page is not submitted correctly.

I turned off the inline html editor, and everything is fine. It doesn't seem to be the editor itself, though, because if I add an html element in one of the plain text fields (just a "<br/>" or the like), I run into the same error.

So my guess is this is some obscure PHP permissions issue or other error-- hopefully this is an easy to recognize and common issue, but I have no idea where to start.

Please Log in to join the conversation.

More
4 years 11 months ago #89241 by jelo
jelo replied the topic: Aw: Settings page unable to submit/page redirects when fields include html eleme
Is the content of the textfields relevant? Is the problem occuring, even when you just try to save one character? Or only with certain content?

Are you having root access to WHM/Cpanel? Or are you just haven access to the Cpanel Part? I would be on ModSecurity Rules or Suhosin settings.
Without error logs it is hard to find the real issue?

Guess you are using Installtron or Fantastico to install Limesurvey. They may have an old version. I would try to install by hand to ensure a clean installation.

Please Log in to join the conversation.

More
4 years 11 months ago #89243 by ewohwerd
ewohwerd replied the topic: Aw: Settings page unable to submit/page redirects when fields include html eleme
The content does seem to matter. I am able to submit plan text without problems, seemingly without a character limit. As soon as I add special characters (it seems < or / may do the trick), that's when I get a redirect and saving changes fails.

The installer was softaculous -- and I have updated with the latest builds as prompted. The initial install happened about two weeks ago or so, so that was my initial install.

I do have full access to cpanel, but I'm not entirely sure what I'm looking for. I'll see what access logs have to say. THanks for your help-- please send along any other advice based on the additional details above.

Please Log in to join the conversation.

More
4 years 11 months ago - 4 years 11 months ago #89245 by ewohwerd
ewohwerd replied the topic: Aw: Settings page unable to submit/page redirects when fields include html eleme
To add additional detail, it looks like it's 404'ing out on some requests for some reason...

"GET /survey/index.php/survey/index.php/admin/database/index/updatesurveylocalesettings HTTP/1.1" 404 1192

However, I am seeing some successful 302 codes for posts to the same location.

I just went and tried submitting a field with some <>'s, and it worked fine. "/" seems to be the problem.
Last Edit: 4 years 11 months ago by ewohwerd.

Please Log in to join the conversation.

More
4 years 11 months ago #89247 by jelo
jelo replied the topic: Aw: Re: Aw: Settings page unable to submit/page redirects when fields include ht
Since Cpanel / WHM is used often in the same way I have to ask again:
Do you have acces to WHM and EasyApache? Do you know how to compile an Apache via the WHM/Cpanel Gui.

I think your problem come from an ModSecurity Rule which needs to be deactivated for your account. This problem is often posted in this forum.
E.g. www.limesurvey.org/de/forum/installation...sues/88981-404-error

If you have an Admin/Provider which provides the CPanel account ask them about problems with certain php scripts and mod security. Would be nice if you could find out which rule causes the problem. You admin/provider can tell you.

Please Log in to join the conversation.

More
4 years 11 months ago #89272 by ewohwerd
ewohwerd replied the topic: Aw: Re: Aw: Settings page unable to submit/page redirects when fields include ht
Thanks so much for your help-- it was indeed a mod_security issue. What masked the problem for me was my site settings were also redirecting on 404 so it took looking at sitelogs to confirm what exactly was happening.

Please Log in to join the conversation.

More
4 years 11 months ago #89280 by jelo
jelo replied the topic: Aw: Re: Aw: Re: Aw: Settings page unable to submit/page redirects when fields in
Could you tell us which rule was causing the trouble. Most rulesets have id numbers to easily identify the rule. Thanks.

Please Log in to join the conversation.

More
4 years 11 months ago #89281 by ewohwerd
ewohwerd replied the topic: Aw: Re: Aw: Re: Aw: Settings page unable to submit/page redirects when fields in
Unfortunately the admin did not specify what the change was. Thanks.

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!