Certain functions of the administrator aren't showing up.

More
4 years 8 months ago - 4 years 8 months ago #89178 by Bjeaurn
Bjeaurn created the topic: Certain functions of the administrator aren't showing up.
Hi,

I've just installed LimeSurvey on a Windows Server 2008 with IIS (it was a pain in the ass because the security permissions on Windows are just silly, but we got it working eventually).

Now there seems to be a problem with the executing of actions within the controllers. When I try to go to edit my admin user, it just keeps going back to the user overview page.

Same goes for creating a new survey, it just keeps on showing me the survey overview page.

I firstly though it was something POST/GET related, but that does seem to work (I've tried doing some print_r()'s to see what was getting passed). I have no clue what could be going wrong and if it's IIS related.

I have another version running locally on my laptop (Mac, so UNIX based) with just regular Apache and that works like a charm.

Did anyone else run into these problems or do you have any idea how I could fix these?
Last Edit: 4 years 8 months ago by Bjeaurn.

Please Log in to join the conversation.

More
4 years 8 months ago #89365 by Bjeaurn
Bjeaurn replied the topic: Certain functions of the administrator aren't showing up.
I've done some testing around, installed it on another Linux box and it worked flawlessly, so I'm guessing it really is IIS/Windows Server related.

I also noticed that I can't use the /admin/ functionality provided by Linux systems. I'm wondering if this might be the original cause of the problem.

I am not sure how the routing is done within LimeSurvey, but my guess is that it breaks on that.

Anyone can explain how the routing is done? Is that htaccess (mod_rewrite) or something like that?

Please Log in to join the conversation.

Did you already participate in our customer survey?

Don't miss your chance for great prices.

Please click here to participate:

Start now

Start now!

Just create your account and start using Limesurvey today.

Register now