Keep getting redirected to limesurvey/index.php/install

More
4 years 8 months ago #87036 by firelight81
firelight81 created the topic: Keep getting redirected to limesurvey/index.php/install
Help! I'm upgrading to limesurvey200plus-build121017.

Everything looks like it working - I get to the LimeSurvey installer configuration page. Type in the details for the MySQL server and then get the following message

"The database you specified is up to date. You'll be redirected in 5 seconds. If not, click here."

When it redirects it goes back to the start of the LimeSurvey installer. What am I doing wrong? I've cleared my cache, tried accessing limesurvey/admin to see if I can log in but it all re-directs to the LimeSurvey installer - help :(

Please Log in to join the conversation.

More
4 years 8 months ago #87177 by carsten
carsten replied the topic: Keep getting redirected to limesurvey/index.php/install
Hi there,

I have a very similar problem, maybe ;-)

I already had a working version of limesurvey200plus-build121019.tar.gz running on my host.

Because I need SSL and have an old server with an Ubuntu Hardy in use (ok, that's another story) I recompiled openssl and Apache version 2.2.23 today. It looked good as all websites were running w/o problems.

Limesurvey does make problems now that I can't define any further. I can't open any user or surveys, they just won't open. Already tried reinstalling the whole setup with database, etc.

Activating the debug-mode it throws an exception (see attachment for full view):
The URL pattern "<_sid:\d+>/lang-<_lang:\w+>/tk-<_token:\w+>" for route "survey/index/sid/<_sid>/lang/<_lang>/token/<_token>" is not a valid regular expression.

Looks like any problem with mod_rewrite, but it's there, ist recompiled and it is working in other instances, so does anyone got further hints where to follow up debugging this?

Thanks in advance!
Carsten
Attachments:

Please Log in to join the conversation.

More
4 years 8 months ago - 4 years 8 months ago #87255 by carsten
carsten replied the topic: Keep getting redirected to limesurvey/index.php/install
Ok I got the solution of my issue. I spend a little time today to take a look at the Yii-Framework and I found out that it needs the (new) pcre-support (Perl Compatible Regular Expression Library) which is integrated since Apache 2.2.x but needs to be enabled by attaching the option --with-pcre to ./configure. This integrates a library that is supplied with the httpd-packet which won't work, but doing it the "Ubuntu-way" works perfectly:
apt-get install libpcre3-dev
./configure --with-pcre=/usr --enable-layout=Debian --with-program-name=apache2 --enable-logio --disable-actions --disable-authn-file --disable-authn-default --disable-authz-groupfile --disable-authz-host --disable-authz-user --disable-authz-default --disable-auth-basic --disable-include --disable-filter --disable-env --disable-setenvif --disable-mime --disable-status --disable-autoindex --disable-asis --disable-cgi --disable-negotiation --disable-dir --disable-userdir --disable-alias
Source: help.ubuntu.com/community/UpgradeApacheHTTPServer

So sorry firelight81 for spamming your thread. Have you checked wheather there are other .htaccess-files or rewrite-rules in parent directories as they could make trouble, too? Is limesurvey/application/config writeable?
Last Edit: 4 years 8 months ago by carsten.

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now