Installing 2.00+ on Mac OS 10.6: permissions for /tmp and /upload

More
4 years 10 months ago #86815 by octern
octern created the topic: Installing 2.00+ on Mac OS 10.6: permissions for /tmp and /upload
Hi, I'm having problems installing limesurvey 2.00+ on mac OS 10.6. The pre-installation check page says that /upload and /tmp are not writable. I manually changed permissions on both of those directories and everything inside them to 777, but it still gives me the same error.

I also tried moving the upload and tmp directories to my ~/Public directory, which is definitely world-writable, and putting softlinks to them in the limesurvey directory (I had to do something similar when I installed Moodle). This didn't fix the problem either. Does anyone have any advice?

Please Log in to join the conversation.

More
4 years 10 months ago #86818 by Mazi
Mazi replied the topic: Installing 2.00+ on Mac OS 10.6: permissions for /tmp and /upload
This might be related to some advanced right management. If you manually change folder permissions, this doesn't always mean that the webserver is allowed to write into these folders as well.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
4 years 10 months ago #86860 by octern
octern replied the topic: Installing 2.00+ on Mac OS 10.6: permissions for /tmp and /upload
Do you have any suggestions about how else I could try to change it or how I could investigate further?

I tried creating a php script that writes to limesurvey/tmp/ and running it from a browser, which should cause it to run with the same permissions limesurvey has. It was able to create a new file in tmp/ and also to append to an existing one. This makes me think that the permissions are set correctly, but limesurvey isn't detecting them.

Please Log in to join the conversation.

Did you already participate in our customer survey?

Don't miss your chance for great prices.

Please click here to participate:

Start now

Start now!

Just create your account and start using Limesurvey today.

Register now