Warning: fread() function.fread: Length parameter must be greater than 0 in /lim

More
4 years 9 months ago #84505 by larrywcc
larrywcc created the topic: Warning: fread() function.fread: Length parameter must be greater than 0 in /lim
Hello I can not install because I get this error
Warning: fread() function.fread: Length parameter must be greater than 0 in /limesurvey/classes/php-gettext/streams.php on line 120
I did find a fix at
docs.limesurvey.org/Installation+FAQ#Whe...ally_fail_to_show_it
mbstring.func_overload = 0 is set in the php.ini

But I still get that problem. So I went into streams and comment out the function and the program works great. Not sure of the purpose of that function if it is really needed or what?

Running on
VPS SERVER

PHP Version 5.2.17

Runs on its own php.ini

Please Log in to join the conversation.

More
4 years 9 months ago #84592 by Mazi
Mazi replied the topic: Warning: fread() function.fread: Length parameter must be greater than 0 in /lim
Commenting out such a function is nothing I can recommend, problems might show up later, e.g. when using multilingual surveys.

Better try to fix this, e.g. by re-uploading all files in binary mode (maybe some files were broken during upload) and by searching the forum for such an error message.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now