Failure to find mySQL database on install of V2RC7

More
4 years 7 months ago #83880 by kaval
I cannot successfully install!

I am pretty sure my PHP 5.3.14 and mySQL 5.1.63 are working ( www.vmcrad.org/phpinfo.php ) but when I try to do an install using vmcrad.org/quiz it fails to allow me to configure a mySQL database, or any database as far as I can tell. Is this possibly an installer error as the host seems to think the DBO driver for mySQL is fine.

I would like to get this working as soon as possible, otherwise I will need to go to the main stable releases.

Are the bar chart statistics now working on RC7?

Thanks,

Please Log in to join the conversation.

More
4 years 7 months ago #83882 by c_schmitz
You have to have a PDO mysql driver installed. If it is proper installed in your phpinfo would show up sections named PDO and pdo_mysql.

Best regards

Carsten Schmitz
LimeSurvey project leader

Please Log in to join the conversation.

More
4 years 7 months ago #83887 by kaval
I found this: After 2-3 hours of googling,found out that it happens because PDO is part of php 5.3(which is my current verison).Since php 5.3 pdo has been moved from pecl to php-core.You can cross check it by listing the configured modules in php

At a terminal level, when I type php -m in looks like PDO is actually installed. You are welcome to try the install at vmcrad.org/quiz.

Here is the output:
php -m
[PHP Modules]
bcmath
bz2
calendar
Core
ctype
curl
date
dom
enchant
ereg
exif
filter
ftp
gd
gettext
hash
iconv
imap
intl
ionCube Loader
json
libxml
mbstring
mcrypt
mysql
mysqli
openssl
pcre
PDO
pdo_mysql
pdo_sqlite
Phar
posix
pspell
Reflection
session
SimpleXML
soap
sockets
SPL
SQLite
sqlite3
standard
tidy
tokenizer
wddx
xml
xmlreader
xmlrpc
xmlwriter
xsl
Zend Guard Loader
zip
zlib

[Zend Modules]
Zend Guard Loader
the ionCube PHP Loader

Please Log in to join the conversation.

More
4 years 7 months ago #83892 by kaval
I contacted the host and agreed with you that for some reason a driver was missing. Will try again soon, but seems as though you may be correct.

Please Log in to join the conversation.