Ver 2 RC 7 : install attempt returns: "No input file specified. "

4 years 8 months ago #83729 by abita1
I downloaded version 2 RC7, and encountered this problem, on MadDogDomains [which may be a derivative of GoDaddy...?]

HTML Page returned on the install attempt is:
""No input file specified. "

I don't notice anything that perplexed me in the .htaccess, at the LS2 root [and I looked because I have, from time to time, encountered odd issues on modules.]

I ran the install string in my browser as per the install instruction, using the install directory on my server, ie:

Interestingly, although I haven't yet installed the Ver 2, the same error is reported if i use "admin" instead of "installer". I would have expected a separate error... and ....

This made me wonder what substitutes [with Ver 2] for modifications for the config.php in the old install instructions for earlier versions.

Also, if these comments help...:

The same error is returned with
as with

However...the first variant returns a web page which has been redirected, to the URL of the second page [with that same error...]

I notice that, in the installer sub-directory, there are only 3 folders, and no files outside of those folders. Is this expected ?

Thanks . . .

Please Log in to join the conversation.

4 years 8 months ago #83731 by c_schmitz
Check the permissions of the uploaded files.

Best regards

Carsten Schmitz
LimeSurvey project leader
The following user(s) said Thank You: abita1

Please Log in to join the conversation.

4 years 7 months ago - 4 years 7 months ago #83742 by abita1
Ah... !

I see now that I hadn't looked at the file permissions to allow owner/execute access on the PHP files. FileZilla, my ftp client, uploaded all files as 604, and all directories as 705

So, this raises a question and suggestion. In the install directions, there is no mention/link to the overall settings required, say, for security purposes.... I now assume 704 is sufficient for all files, and that 705/755/777 are required for the TMP and UPLOAD folder. Or, for security reasons, should auth be granted only to PHP files [a time consuming step, for sure...], leaving all other files as 604, or less?

I didn't notice one, so a comment that instructs and resolves the issue might could be slid into the upload part of the install directives....

Apologies in advance if I missed that, too.

Also, on a tangential topic -- given the large step from 1.92+ to 2.00 that might be inferred, the manual should explicitly state it applies to 1.8x+ and also to 2.00+. Or should be a clone of the 1.x manual to a set of 2.0 directories reflecting the 2.0 changes ...?

It would be nice, too, if the install instructions found on the 2.00RC7 download page mentioned the new instructions, instead of the 1.x variant. The 2.0 info was buried on a reference in the root readme to the docs folder's install.txt, within which was the simplified instruction

Thanks for the helpful hint/help !
Last Edit: 4 years 7 months ago by abita1. Reason: minor

Please Log in to join the conversation.

4 years 7 months ago - 4 years 7 months ago #83755 by abita1
I wonder if I understood this correctly...the ChMod changes do not correct the problem; I've noted additional observations, below:

I notice that Zencart, installed on my server by the IPS, has File=604 and Directories=705. Now, it executes at least the initial/login php files, there. So I suspect that the default upload permissions are right . . . ?

I had a then-current test version of LS 1.x, up and running a year ago, and that worked without problems. I hadn't tested it in about a year, and I can't test whether it would have worked now since I deleted it on the server before loading ver 2.

I turned off my root .htaccess, just in case, to no avail.
I notice that my PHP is 5.3.13
On my domain, the 5.3.x PHP extension has FastCGI enabled -- I'm not sure if this is an issue, but read about it being an issue if the file is missing. However....the php file -is- there, and I can access the README in the same directory with a browser.
The ISP reports that it runs PHP as CGI, and that it runs Apache 1.3.3
The PHP 5 function register_globals is turned off by default.
I do not have a php5.ini file in my root.

There is a php.ini file [not "php5.ini"], placed at my domain root by zencart, which has this content:
register_globals = off
allow_url_fopen = off
expose_php = Off
max_input_time = 60
variables_order = "EGPCS"
extension_dir = ./
upload_tmp_dir = /tmp
precision = 12
url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=,fieldset="
Last Edit: 4 years 7 months ago by abita1.

Please Log in to join the conversation.

4 years 7 months ago #83770 by abita1
Addendum: The phpinfo.php file runs appropriately both from my domain root, and from the limesurvey2 subdirectory into which the LS2 directories/files have been uploaded.

My ISP states that the "php.ini" file, above, stashed in my root directory, is supposed to control Ver 4x of PHP. To create a INI file for ver 5.3, I would have to create the file php5.ini. As noted, above, I have -not- created a php5.ini file -- neither in the domain root nor in the LS2 directory.

Please Log in to join the conversation.