Check out the LimeSurvey source code on GitHub!
Welcome, Guest
Username: Password:

TOPIC: admin/admin.php was not found on this server

admin/admin.php was not found on this server 4 years 4 months ago #83162

  • Blaise
  • Blaise's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 18
  • Karma: 0
Hello

I installed LimeSurvey locally, using Mamp (on a Mac, of course)

I suppose it went right since I could access limesurvey/admin/admin.php and get the "You have to login first"
I did try, using "admin" as Username and "password" as ... password.

Then I get the following message:
"The requested URL /limesurvey/admin/admin.php was not found on this server."

I am a bit puzzled :huh: , since in my understanding admin.php is generating the login form...

How can I solve that ?
Thanks
The administrator has disabled public write access.

admin/admin.php was not found on this server 4 years 4 months ago #83165

  • holch
  • holch's Avatar
  • Online
  • LimeSurvey Team
  • Posts: 5431
  • Thank you received: 809
  • Karma: 240
That sounds like you did something wrong in the config.php with the rooturl.

Could you post the folder where you have LS installed locally and what the config.php says?
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | [url=https://manual.limesurvey.org/Workarounds[/url]

If you found this answer helpful and it saved you some time please consider a [url=https://donate.limesurvey.org[/url] to the...
The administrator has disabled public write access.
The following user(s) said Thank You: Blaise

admin/admin.php was not found on this server 4 years 4 months ago #83168

  • Blaise
  • Blaise's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 18
  • Karma: 0
holch wrote:
That sounds like you did something wrong in the config.php with the rooturl.
Me? Something wrong? Last time was years ago!
holch wrote:
Could you post the folder where you have LS installed locally and what the config.php says?
About rooturl, the config.php, line 44, said
$rooturl = "http://{$_SERVER}/limesurvey"

Following your remarks, I changed it to incorporate path info
$rooturl = "http://{$_SERVER}/NNQ/Quest/limesurvey"
and... it worked!

Thanks a lot, holch!
The administrator has disabled public write access.

admin/admin.php was not found on this server 4 years 4 months ago #83171

  • holch
  • holch's Avatar
  • Online
  • LimeSurvey Team
  • Posts: 5431
  • Thank you received: 809
  • Karma: 240
You are welcome!
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | [url=https://manual.limesurvey.org/Workarounds[/url]

If you found this answer helpful and it saved you some time please consider a [url=https://donate.limesurvey.org[/url] to the...
The administrator has disabled public write access.
Time to create page: 0.548 seconds
Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form