Check out the LimeSurvey source code on GitHub!

Limesurvey 2 RC2 working very slowly

More
4 years 3 months ago #87828 by seanrife
Has anyone figured out definitively what the cause is here? I'm experiencing serious performance issues with all things LimeSurvey 2.0. I had about 20 people filling out the same survey this afternoon, and it got so bad that my host's procwatch killed my php5.cgi process because it was hitting my shared server's memory limit. I'm running the latest version. Viewing responses seems to really soak up the resources, too.

I would file a bug report, but I can't for the life of me figure out enough details to do so. Does anyone have any suggestions? jmattias, how did you disable the outbound packages to LimeService.com?

Running Debian GNU/Linux 6.0.5 (squeeze) on a shared server (DreamHost). MySQL version 5.1.53. PHP version 5.3.13.

Please Log in to join the conversation.

More
4 years 3 months ago #87865 by Mazi
There is a similar bug report at bugs.limesurvey.org/view.php?id=6299 where you can add your details like phpinfo file and other related information.

There seems to be a bottleneck at certain server configurations but we need more details to track this down.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
4 years 3 months ago #87929 by seanrife
Thanks, Mazi - I just did that. Please let me know if there are any other details you need or if I can do anything else to help.

I'd also gladly donate to the project if this could be resolved soon... I'm in the process of collecting data for my doctoral dissertation :cheer: , so it's pretty high on the ol' priorities list.

Please Log in to join the conversation.

More
1 year 5 months ago #124648 by roblange
Hi,

I have installed limesurvey206plus-build150831 and it is really slow, to login and to create a survey.
MYSQL5.6.17
PHP 5.5.12
Server is massive so I doubt its the hardware and I am using windows server 2012 R2 standard.

Any tweaks I can use to make it faster?

Please Log in to join the conversation.

More
1 year 5 months ago #124657 by LouisGac
If your LimeSurvey installation can't reach network, it could be a bug coming from the update checker.
It will be fixed in the next release.
Right now, if you want to fix it quickly by yourself, just edit the file :

application/models/UpdateForm.php

And replace :
            else 
            {
                $next_update_check = $today->add(new DateInterval('P1D'));
                Yii::app()->session['next_update_check'] = $next_update_check;
            }
(should be at line 565)

by :
            else 
            {
                $next_update_check = $today->add(new DateInterval('P1D'));
                Yii::app()->session['next_update_check'] = $next_update_check;
                Yii::app()->session['update_result'] = false;
            }
(just added the line : Yii::app()->session = false; )

Please Log in to join the conversation.

More
1 year 5 months ago #124683 by roblange
Hi,
Ok I tried this and when i make the change all i see is the site name in the top corner of the page. If I change it back then all works again just slowly.

Please Log in to join the conversation.

More
1 year 5 months ago #125614 by Mazi
Maybe there was a minor typo or issue when trying to adjust the code manually?

A new release is available for download since a few days (see www.limesurvey.org/en/downloads/category...atest-stable-release ).
Can you test if this fixes your problem?


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form