Limesurvey 2 RC2 working very slowly

More
4 years 10 months ago #85169 by lpousada
lpousada replied the topic: Limesurvey 2 RC2 working very slowly
Hi everybody,

We’ve been trying to solve this issue using all know-how available.

Last development:
LS2 RC9 installed from scratch on a new VM (similar to the one with LS1.92) with Apache, PHP 5.3.16 and MySQL.Minimum Requirements checked OK as well all Optional modules.

Once again it is very very slow doing anything even login! :(

Thanks in advance for your kind sugestions.

LPousada.

Luis Pousada

Please Log in to join the conversation.

More
4 years 10 months ago #85172 by holch
holch replied the topic: Limesurvey 2 RC2 working very slowly
Runs here like a charm on a xampp installation on my notebook.

Why don't you try it on the same VM-Ware as 1.92 to compare? The two installations can run perfectly fine in parallel, as long as you use different databases.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
4 years 10 months ago #85173 by holch
holch replied the topic: Limesurvey 2 RC2 working very slowly
Sorry! Forget about my post. I only just saw that there was a previous page and you actually had done this before already.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
4 years 10 months ago #85217 by lpousada
lpousada replied the topic: Limesurvey 2 RC2 working very slowly
No problem! We've tried the LS2RC9 with the same VM with LS1.9, after that we installed a new VM from scratch with stable releases of base sw. The rational was: the first VM was been upgraded year after year and could have old stuff blocking.
I must say we are using VM's from our cloud infraestructure (corporate IT privilegies ;-) ) so performance isn't an issue.

Best regards!
LPousada

Luis Pousada

Please Log in to join the conversation.

More
4 years 9 months ago #87009 by jmattias
jmattias replied the topic: Limesurvey 2 RC2 working very slowly

lpousada wrote: Hi everybody,

We’ve been trying to solve this issue using all know-how available.

Once again it is very very slow doing anything even login! :(

Thanks in advance for your kind sugestions.

LPousada.


Have you checked if there's any egress/ingress filtering between your server and LimeSurvey Professional (previously LimeService).com?
When investigating similar issues on one of our setups I noticed dropped outbound HTTP packages to LimeSurvey Professional (previously LimeService).com. After I addressed this it was reported to work a lot better.

Best regards

Mattias.

Please Log in to join the conversation.

More
4 years 8 months ago #87828 by seanrife
seanrife replied the topic: Limesurvey 2 RC2 working very slowly
Has anyone figured out definitively what the cause is here? I'm experiencing serious performance issues with all things LimeSurvey 2.0. I had about 20 people filling out the same survey this afternoon, and it got so bad that my host's procwatch killed my php5.cgi process because it was hitting my shared server's memory limit. I'm running the latest version. Viewing responses seems to really soak up the resources, too.

I would file a bug report, but I can't for the life of me figure out enough details to do so. Does anyone have any suggestions? jmattias, how did you disable the outbound packages to LimeSurvey Professional (previously LimeService).com?

Running Debian GNU/Linux 6.0.5 (squeeze) on a shared server (DreamHost). MySQL version 5.1.53. PHP version 5.3.13.

Please Log in to join the conversation.

More
4 years 8 months ago #87865 by Mazi
Mazi replied the topic: Limesurvey 2 RC2 working very slowly
There is a similar bug report at bugs.limesurvey.org/view.php?id=6299 where you can add your details like phpinfo file and other related information.

There seems to be a bottleneck at certain server configurations but we need more details to track this down.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
4 years 8 months ago #87929 by seanrife
seanrife replied the topic: Limesurvey 2 RC2 working very slowly
Thanks, Mazi - I just did that. Please let me know if there are any other details you need or if I can do anything else to help.

I'd also gladly donate to the project if this could be resolved soon... I'm in the process of collecting data for my doctoral dissertation :cheer: , so it's pretty high on the ol' priorities list.

Please Log in to join the conversation.

More
1 year 10 months ago #124648 by roblange
roblange replied the topic: Limesurvey 2 RC2 working very slowly
Hi,

I have installed limesurvey206plus-build150831 and it is really slow, to login and to create a survey.
MYSQL5.6.17
PHP 5.5.12
Server is massive so I doubt its the hardware and I am using windows server 2012 R2 standard.

Any tweaks I can use to make it faster?

Please Log in to join the conversation.

More
1 year 10 months ago #124657 by LouisGac
LouisGac replied the topic: Limesurvey 2 RC2 working very slowly
If your LimeSurvey installation can't reach network, it could be a bug coming from the update checker.
It will be fixed in the next release.
Right now, if you want to fix it quickly by yourself, just edit the file :

application/models/UpdateForm.php

And replace :
            else 
            {
                $next_update_check = $today->add(new DateInterval('P1D'));
                Yii::app()->session['next_update_check'] = $next_update_check;
            }
(should be at line 565)

by :
            else 
            {
                $next_update_check = $today->add(new DateInterval('P1D'));
                Yii::app()->session['next_update_check'] = $next_update_check;
                Yii::app()->session['update_result'] = false;
            }
(just added the line : Yii::app()->session = false; )

Please Log in to join the conversation.

Did you already participate in our customer survey?

Don't miss your chance for great prices.

Please click here to participate:

Start now

Start now!

Just create your account and start using Limesurvey today.

Register now