Continued Installation Roadblock for 2.0RC2

More
5 years 3 weeks ago #81395 by rx2
rx2 created the topic: Continued Installation Roadblock for 2.0RC2
I have created a database and put the LimeSurvey files under a folder on the web server called ls2.

I go to the following URL:

thedomain.com/ls2/index.php/installer

I get the following error:
No input file specified.

Reading another thread about this it was mentioned that the config.php had an erroneous $rooturl setting but I unzipped limesurvey200RC2-build120528.zip directly into the folder and moved the files from ls2/limesurvey to ls2. The only config.php files in the archive appear to be in:

scripts/admin/kcfinder framework/messages [code] Specs ------ DB: MySQL 5.0.92 PDO Driver: 5.0.77 PHP: 5.2.17 Have a successful install of 1.92 but have no idea if we can just try to install 2.0RC2 over it so have been trying a separate install but on the same server in the same web root. Maybe that is an issue?[code]
scripts/admin/kcfinder
framework/messages
Specs ------ DB: MySQL 5.0.92 PDO Driver: 5.0.77 PHP: 5.2.17 Have a successful install of 1.92 but have no idea if we can just try to install 2.0RC2 over it so have been trying a separate install but on the same server in the same web root. Maybe that is an issue?[code]

Specs
DB: MySQL 5.0.92
PDO Driver: 5.0.77
PHP: 5.2.17

Have a successful install of 1.92 but have no idea if we can just try to install 2.0RC2 over it so have been trying a separate install but on the same server in the same web root. Maybe that is an issue?

Please Log in to join the conversation.

More
5 years 2 weeks ago - 5 years 2 weeks ago #81475 by bquast
bquast replied the topic: Continued Installation Roadblock for 2.0RC2
I get the same problem (GoDaddy hosting, not sure if that matters). Anyway played around a bit, when I go to:

/installer/welcome

I can see the installer but, every new page creates the same problem. I.e. the base path seems to be set wrong, but I don't know how to correct this.
Last Edit: 5 years 2 weeks ago by bquast.

Please Log in to join the conversation.

More
4 years 11 months ago #83762 by abita1
abita1 replied the topic: Continued Installation Roadblock for 2.0RC2
I had the same problem, yesterday, with 2.0RC7.

And my reaction is the same: A solution provided by a user, 1.5yrs ago, imputed the correction to explicitly declaring the $rooturl in the config.php.

However, the install mechanism for the 2.0 variants doesn't work the same way, and there is not, for me, an apparent way to make changes. I have filed my own forum question on the matter, along with status of the PHP install, and other issues, in case a reviewer wants to look-see there.

Please Log in to join the conversation.

More
4 years 11 months ago #83763 by holch
holch replied the topic: Continued Installation Roadblock for 2.0RC2
First of all I want to highlight that we are talking about RC = Release Candidates. Those versions of 2.0 labled with RC are not yet ready and stable releases, so you should only install them for testing and bug tracking purposes, not as a production version with actual surveys running.

That said let's try to fix this problem. First of all, LS 2.0 is quite different to the previous versions, so solutions posted for 1.9x or earlier might not be solving the problem, as you have already perceived.

When you say that you installed LS 2.0 in parallel to a working LS 1.92 install, do you use the same database or is the database different?

So you actually did not start the installation process? The error message is already there?

Are you sure that you copied all files correctly, because the approach of uploading things to the folder ls2/limesurvey and then copying it to ls2 folder sounds like there could have been a problem during this process.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
4 years 11 months ago - 4 years 11 months ago #83766 by abita1
abita1 replied the topic: Continued Installation Roadblock for 2.0RC2
I was installing V2RC7 as a test bed, not for production. And, I do recognize that there is a distinct install mechanism, which I allude to in my posts here and elsewhere.

I didn't say I made a parallel install...I had previously installed, and then deleted a few days ago, the prior version on this server.

The problem is that I can't get the install on ver 2 to even start. That problem in the same form is reported on earlier versions [1.8/1.9] with a range of causes/solutions suggested/found, but is also reported in the context of Ver 2.

I am pretty sure that the install is correct. I did a second d/l to my local machine, and checked to see if the files, the offending files as I guessed it, were the same, and they were.

See my originally posted forum note, at:

http://www.limesurvey.org/en/forum/installation-a-update-issues/83729-ver-2-rc-7--install-attempt-returns-qno-input-file-specified-q#83731

sorry...it seems the url reference coding slithers a little...I can't get it to display correctly, but it looks like the first part of the link actually points to the correct place

Thanks for taking the time to consider possible solutions for me...
Last Edit: 4 years 11 months ago by abita1.

Please Log in to join the conversation.

More
4 years 11 months ago #83768 by abita1
abita1 replied the topic: Continued Installation Roadblock for 2.0RC2
An addendum:
In response to your comment about copying correctly:

I downloaded the LS2 zip file to my local Win7 Machine, and copied/unzipped the internal files [ie, the ones inside the zipped LS folder] to my local machine. With the files placed in a local directory "limesurvey2", I then uploaded the entire pile to a directory on the Linus/Apache 1.3.3 server by the same name, using a binary FTP.

I pointed to the install URL as:
www.mydomain.com/limesurvey2/index.php/installer

and received the returned error page, with this sole content:
"No Input File Specified"

While I received that error attempting an install, I was able to execute a phpinfo.php stored in the root directory of my machine, and could run ZenCart and its PHP [from which I conclude there is something specific to the LS install, and the way my ISP interacts with it...? This behavior, I allude to above, is reported on installs with prior versions, and on this ver 2. One cure, to amend the $rooturl variable in a config.php at the LS root, is not available to me, as the LS install bureaucracy has changed.

Please Log in to join the conversation.

More
4 years 11 months ago #83769 by abita1
abita1 replied the topic: Continued Installation Roadblock for 2.0RC2
And merely because I was curious, I just now uploaded the phpinfo.php to the LS2 directory, and ran it over my browser, from there.

That file runs as expected, so I don't fathom something untoward in the .htaccess at the LS2 directory

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now