Check out the LimeSurvey source code on GitHub!

Error since upgrade to 1.92+ 'no matching survey' after 'resumes later'

More
4 years 8 months ago #80002 by ijattala
Hello:
Ever since we upgraded to version 1.92+ (120425) the use of "Save and Resume Later" option generates two particularly weird behaviors.

1) The response for many users (NOT all) after clicking on the email link is "There is no matching saved servey".

2) Those who are able to get to the saved survey after clicking the link, are unable to use "Save and Resume Later" option again unless each time they provide new and different save name and password.

The problem are reported on all web browsers, (IE, FF, Chrome, etc).

Please Log in to join the conversation.

More
4 years 8 months ago #80068 by TMSWhite
For #1, have you checked whether those users completed the survey? If they click "Save and Resume Later", but then complete the survey, the resume record is removed.

For #2, the is the current default behavior. If you give users tokens and enable "token-based persistence", they won't need to re-enter a username/password each time.

Please Log in to join the conversation.

More
4 years 8 months ago #80069 by ijattala
Thanks for the reply: OK, for #2, we will work around it until we learn to use tokens.

As to #1 (people not being able to get back to their survey after 'Save and Resume Later") users report not completing the servery and still survey not being available to edit. (this complaint is from at least half of our users)

Actually, in our org, we use survey to collect data and as a procedure one person starts the survey, and uses 'Save and Resume Later" so their supervisors can review the data and submit.

However, when supervisors tries to get to the saved survey either from the link or by by using name ID/Password combination, the survey is no longer available; and it shows up as completed in the admin area.

Also, is there a workaround to reset the survey so that it can be logged in again?

Please Log in to join the conversation.

More
4 years 8 months ago #80072 by Mazi
There has just been a fix for the "resume later" feature: github.com/LimeSurvey/LimeSurvey/commit/...3bf26ee3b3cb43cdebe4


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
4 years 8 months ago #80078 by ijattala
Thank you. How do I make use of this fix?

Please Log in to join the conversation.

More
4 years 8 months ago #80112 by Mazi
You can always get the latest files from Github: github.com/LimeSurvey/LimeSurvey

...or wait for the next weekly bugfix release.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
4 years 8 months ago #80137 by ijattala
Great. Thank you very kindly.

Please Log in to join the conversation.

More
4 years 8 months ago #80205 by Mazi

ijattala wrote: Great. Thank you very kindly.

You're welcome :-)

If our hints have been helpful and you enjoy limesurvey please consider a donation to give Limesurvey a future .
We do all this in our free time and you don't have to pay a penny for this software.

Without your help we can't keep this project alive.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
4 years 8 months ago #80529 by ijattala
OK, so here is the latest. After updating to the latest update now the screen is all messed up rendering the admin ares useless.

While the field and drop-downs are visible, most of the text on screen as well some from the fields is not visible. Please see attached screenshots.

Please help... our work stopped :(
Attachments:

Please Log in to join the conversation.

More
4 years 7 months ago #80823 by ijattala
did anyone had a chance to review this above post....

Please Log in to join the conversation.

More
4 years 7 months ago #80824 by mdekker
There were some problems with translations, I would advise to upgrade to the latest version, that will probably fix your missing text.

---
Menno Dekker

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form